Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Following the instructions in this thread, I added the Dvorak layout to the Regional and Language Options control panel, set it as the default keyboard layout and removed the US (QWERTY) layout.

However, even though I removed the QWERTY layout, it still appears in my language bar, and my system defaults to it in every new window. This persists after a log-out/log-in and even a system restart.

I have noticed this behavior in multiple versions of Windows, including Windows XP and Windows Server 2008.

Screenshot of QWERTY layout selected with Regional and Language control panel open showing that only Dvorak is active

How do I remove the QWERTY keyboard layout from my system permanently?

Alternatively (if outright removing QWERTY is just impossible), can I get Windows to default to Dvorak instead of QWERTY for new windows/documents?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You should be able to remove the keyboard layout by removing it, but as in your case it can't be done, the second (alternate) option seems more apt at the moment till someone else can figure that out. What I can show you is how to set DVORAK to be your default keyboard layout.

Firstly you need to set DVORAK to be your default input language and apply the changes. This will set it to open all your programs with the DVORAK layout by default.

region and language settings

You can also configure a keyboard shortcut to switch between keyboard layouts or input languages. In your case will be your keyboard layout to left alt + shift on your keyboard. Just in case your layout settings are acting nasty and not setting it to DVORAK by default.

change layout

share|improve this answer
1  
Thanks for your response. I have updated my OP with a screenshot. The only difference between what I have tried and what you have suggested is that I outright removed QWERTY from my list of installed layouts. Perhaps that is where I went wrong. –  todofixthis Mar 27 '11 at 20:07
1  
Also, the keyboard shortcut workaround can be augmented by assigning the Dvorak layout a different icon than QWERTY so that it is easier to tell when a window is using one or the other. Good tip, though; so far, this has been the keyboard layout equivalent of life support for me! –  todofixthis Mar 27 '11 at 20:09
1  
can you add QWERTY back and then change the default layout to DVORAK and then remove QWERTY it again. Maybe that can help? –  rzlines Mar 27 '11 at 21:15
    
Huh. That seems to have done the trick! Thanks for your help! –  todofixthis Mar 27 '11 at 21:18
    
Glad that this solved it for you.. I think I did that once so was hoping that would solve it. –  rzlines Mar 27 '11 at 23:42

I know this is really late, but the removal of QWERTY will not take full place until after a reboot or two.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.