Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have an ASUS P7P55D-E Pro motherboard. It has an on-board Realtek 8112L LAN controller w/ AI NET2. I suspect that my LAN controller is dead but I don't really know for sure. This is what I know thus far:

  • Everything was working, I have a triple booted system and ethernet was functional under Linux, Win7, and OSX.
  • My ethernet is no longer functional under all three of the operating systems.
  • I was experiencing random momentary internet outages before everything finally went dark.
  • I don't know much about the AI NET BIOS tool but I believe it just checks for ethernet problems before you boot into an operating system. In any case, it doesn't find a connection upon boot.
  • I've checked the connection on a couple of other machines and everything worked fine.

I think I already know the answer to my question, but are there any other possible explanations, or is it dead?

share|improve this question
up vote 5 down vote accepted

Try reseting the CMOS by removing the battery or jumper method (moving the jumper from pins 1-2 to pins 2-3). Did you lose power recently or brown outs? If your onboard NIC is shot, you could always purchase a PCI NIC card for cheap.

share|improve this answer
thanks for the advice. No brown outs, I am also attached to a UPS. I'll try reseting the CMOS. – Usagi Feb 11 '11 at 22:09
thanks a lot, that did the trick. I don't understand why it worked but it did :) – Usagi Feb 13 '11 at 20:17
@usagi - Weird! Grats and nice suggestion from ngen. – Shinrai Apr 11 '11 at 23:28
It seems the only way to prevent this from happening again is for someone to update the drivers. – Usagi Apr 11 '11 at 23:30
Thanks, this worked for me too. – atlau Apr 13 '14 at 18:02

You've pretty much done everything except one easy check: the easiest check with a known working connection is to plug into that exact cable and look at the link lights on the ethernet port; if the card is completely shot they'll probably not be on whatsoever. (This isn't foolproof but if an ethernet port gets shorted out from static this will almost ALWAYS result. It's certainly the easiest first thing to check).

share|improve this answer
that's a good point. I did notice that there were lights (yellow and orange) so that is one positive sign I suppose :) – Usagi Feb 11 '11 at 22:23
@Usagi - A confusing sign at this point. When you tried under Windows, how did the LAN device show up under Device Manager? – Shinrai Feb 11 '11 at 22:29
It didn't show up under network connections at all. Under device manager it was listed as an unknown device. – Usagi Apr 11 '11 at 23:27
I have a very similar problem with a dead NIC with orange/yellow lights but I am able to see the device named correctly. The adapter is unable to get IP configuration settings. Not fixed yet. – Enigma Feb 20 '13 at 15:18
Does no lights plus not working almost always mean the port is shot? – fredsbend Aug 20 '14 at 20:28

Have you installed Ubuntu? It seems to mess up the controller pretty good. I tried Ubuntu live cd without installing it few days back and today my Realtek 8112L stopped working in windows. Ubuntu messes with bios settings or something for the LAN controller.

Clearing the RTC RAM worked for me. Loading bios defaults did not help.

share|improve this answer
I am using Ubuntu 10.10. I have been trying a number of things to narrow down the problem and make it more reproducible and clearing the CMOS consistently fixes the problem. So far this is what I have been doing to reproduce the problem: log into Linux, use the internet, switch to Windows, and then I put the computer to sleep a couple of times. Usually the second time Windows is woken from sleep the ethernet card will be missing. I would love to hear more about your situation. – Usagi Mar 7 '11 at 4:13

I MUST tell ; I tried ALL of the above without results and I couldn't accept to lose that connector right now (online exam tomorrow...). I had no lights on the connector, a working internet connection, and the latest drivers were correctly installed. I suggest to anyone do this little last move before you buy anything...

  • Unplug PSU and CLEAN THE CONNECTOR! (I used a q-tip and rubbing alcohol, then cleaning duster)

For some reason, there was a bit of white corrosion on this brand new Mobo I've been using for almost a month...eureka!

share|improve this answer

Well, my problem has been solved after clearing RTC RAM since i didnt actually install ubuntu. I found a thread which might help you:

share|improve this answer

For what it's worth, after a bit of research, I've found that this issue pops up if I build the r8168 driver for this NIC (source available from Realtek's site) and both drivers are loaded at the same time. Resetting the BIOS resolves the issue though.

share|improve this answer

Seems it's quite usual for some brands/model like Realtek Gigabit onboard chips. I thought my Asus Z97 onboard LAN was dead until I decided to power off the computer completely (remove power cord) for a little while and suddenly it became alive.

In my case, this appeared after some power outage. Maybe some internal state (embedded controller memory) stayed in some inconsistent state, I dont know.

share|improve this answer

I was stuck with this problem for several days, thinking the motherboard ethernet chip may have died. I was about to buy a new PCI ethernet card, til i found a post that saved me. All I had to do was to turn off the computer, unplug the PSU, leave it off for a few minutes, then plug it back in and boot again, then it worked again!!!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .