Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Thinkpad T410s running Windows 7 64-bit. I have had it for three months. It has the latest BIOS (1.41) and trackpad drivers.

In the last week I have started to notice that the keyboard intermittently stops working.

Specifically, keystrokes have no effect, including Fn-F12 (shutdown) and Ctrl-Alt-Del. The LED on the capslock key does not turn on or off. Whatever state the lighted keys (e.g. mute) were in remains. The trackpad and trackpoint work properly, and I can close apps and properly shut down the machine. When I attach a USB keyboard it is recognized, but no keys work.

If I run the Lenovo keyboard test, all the keys register properly and the caps lock light works again. When I quit the test app, the caps lock light stops working. If I hit Fn-F12 while the keyboard test is running, it goes into hibernation. When the machine comes back from hibernation, once I exit the keyboard test I again cannot do any input on the keyboard.

I'm pretty convinced there is a software or driver problem. I never saw this the first three months I had the laptop. I do not recall installing anything recently. I am sure I've received some Windows security updates. I tried using wired networking instead of wireless - no difference. There doesn't appear to be any inciting event; it usually happens when I am working over ssh. I switched from rxvt+ssh to Putty and the problem still occurs.

Any ideas?

share|improve this question

migrated from serverfault.com Feb 12 '11 at 4:21

This question came from our site for system and network administrators.

up vote 1 down vote accepted

I was experiencing Windows 7 "Filter Keys". By default, if you hold down the right shift key for 8 seconds, the Filter Keys mode activates. This is supposed to slow down input, but in my case none of my keystrokes were having any effect. As a hint, the system does make a "tick" noise when you touch keys on the (disabled) keyboard, but since I usually have my system on Mute I didn't hear anything.

Why was I activating this in my SSH sessions? When I use terminals I frequently hold down right shift and page up/down to access the scrollback buffer. I can easily lean on it for 10 seconds or more.

Solution is to go to Control Panel -> Ease of Access Center -> uncheck "Turn on Filter Keys".

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .