Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it just me, or is Windows 7 x64 awfully unstable when it comes to 32-bit processes? If I ever find myself in a situation where a 32-bit process hangs or otherwise misbehaves, terminating the process (through e.g. task manager) seems to fail every time - there are no error messages or anything, it's just that the process refuses to terminate.

Anyone else have the same problems running 32-bit applications on x64 Windows?

Thanks,

Will.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I don't think that is normal, as I've never had a problem like that.

Have you tried using tasklist and taskkill from CMD?

If you are experiencing serious stability problems like that, I would suggest you reinstall Windows.

share|improve this answer
    
Thanks for the response - hadn't previously tried taskkill, have just tried it but to no avail, even with /F switch (force) and when run with administrator privileges. No errors - it reports that the process has been terminated when it evidently hasn't. –  Will A Feb 12 '11 at 14:49

It may be trying to use 32bit dlls and drivers, which won't work. It's very hard to track down, so re-installing is a good idea. When you reinstall drivers look for drivers aimed at 64bit windows 7. Try the program causing the problem as you reinstall others to see if you can narrow it down.

share|improve this answer
    
Thanks tobylane. It does seem to be that any 32-bit process that gets itself hung-up will refuse to terminate, though - regardless of whether it's likely to be using drivers or not. :( Admittedly, in the latest instance of this problem, it was Virtual PC 2007 (x86) that failed to terminate - I can appreciate this could well be a problematic app. to kill. –  Will A Feb 12 '11 at 14:56
    
MS lists Virtual PC 2007 SP1 as being the only compatable version with Windows 7 x64. You might verify that you have SP1 installed as that could be causing you're crashing/freezing issues - microsoft.com/downloads/en/… –  edusysadmin Feb 12 '11 at 16:15
    
@edusysadmin - thanks, yup - I've SP1 installed, but always good to check (set up the PC quite recently and it's all too easy (for me!) to forget installing SPs once I've gotten the software proper installed. –  Will A Feb 14 '11 at 13:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.