Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was using IE9 beta till now and installed IE9 RC today. However it starts crashing on 50% of the sites I visit. This also includes www.youtube.com.

I did not uninstall IE9 beta before installing IE9 RC. Could this be the reason?

EDIT: I have uninstalled IE9 RC and installed it again after restart but that has not fixed this issue.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I would uninstall all versions of IE9, reboot and try installing RC again.

share|improve this answer
    
I tried this but it has not helped. –  Amitabh Feb 13 '11 at 19:39
    
Go to Control Panel > Internet Options > Advanced Tab and hit the reset button, try IE again. –  Moab Feb 13 '11 at 20:34
    
That did not work as well. –  Amitabh Feb 14 '11 at 11:56

Does this occur on pages with flash or any other plugins?
Have you tried checking memory in your computer?

I can't really have any other idea. Other apps misbehave too? (To be honest I don't really have an idea why would you want to use IE9RC if the other apps work like a charm. Like.. it only have GPU accel.. like Chrome and Firefox's latest beta. Nothing new, nothing special.)

share|improve this answer
    
It seems to be happening on Pages with flash. I have 3GB RAM on my machine –  Amitabh Feb 14 '11 at 9:45
    
Try installing Square. labs.adobe.com/technologies/flashplayer10/square | –  Shiki Feb 14 '11 at 13:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.