Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I boot Windows 7, I get the message that says Windows Defender has been turned off (because of Security Essentials). I want Windows Defender off, and I want the message to go away. How do I kill this boot message? I disabled the service, but no effect.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

To Those whom would have you believe that you have to disable Windows Defender from within Defender itself and that "...No other way will actually completely remove the messages...,' I'm sorry but this is INCORRECT!

Yes, If Windows Defender is already On, then you should first Disable it from within the Defender console itself, however in many cases that simply isn't enough.

Once you are sure that Windows Defender is disabled from within the console itself, then proceed with the following steps below...

You can actually DISABLE Windows Defender service from starting up at all and that will get rid of the pesky "Windows Defender reports that the service is turned off" message at startup...

Simply type in [ services.msc ] into the start box and locate Windows Defender on the list.

As soon as you find it, right-click it and click on Properties.

Under the "General" tab where it says "StartUp Type" with a drop-down menu next to it, click on the drop-down menu, select "Disabled" and then click apply at the bottom of that Window.

Exit the services and restart your pc. You should no longer notice that nagging message at startup.

In my opinion, this has got to be one of the most annoying aspects of the Windows Operation System, especially considering the fact that the premise by which Microsoft released Windows 7 and later was to promote a more streamlined OS with less hiccups than what we recall from previous versions.

I mean really---how many end-users, serious about pc security, are going to use MSE for their preferred security system?!

Like IE, Microsoft Security Essentials has its weaknesses and certainly is not my first pick for system security---that said, Microsoft should have instituted its own registry tweak for this particular system scenario so that users aren't endlessly plagued by these stupid and quite useless messages that appear at every startup!

Microsoft already knew many end-users would not opt for MSE and therefore should have designed a Windows registry fix to automatically recognize an Administrator-installed security application for the exclusive purpose of disabling this ridiculous Windows Defender Problem...

...Please!...Don't get me started again on Microsoft's arrogance and stupidity...or I won't quit!...

share|improve this answer

You need to turn off Defender from within Defender. No other way will actually completely remove the messages you indicate. See here

I'll add though, that MSE and Defender work together nicely. No need to do what you're trying to do.

share|improve this answer
    
Since Windows Defender doesn't run, this doesn't help. Stopping the service did not get rid of the boot message. –  xpda Feb 14 '11 at 5:20
    
@xpda - you need to enable the service and disable Defender as indicated in my answer. –  edusysadmin Feb 14 '11 at 19:16
    
When I tried that, Windows Defender would not run because of MSE, so I could not disable it from within Defender. Removing the registry setting prevents Windows Defender from trying to start in the first place. –  xpda Feb 16 '11 at 18:59
    
@xpda - I'd uninstall MSE, undo the reg edits and service changes on Defender and reinstall MSE. As indicated below MSE should disable Defender and MSE should be listed as your tool of choice under the Action Center heading 'Spyware and unwanted software protection'. –  edusysadmin Feb 17 '11 at 0:19

Go to Control Panel (icon view) > Action Center, look under "Security" see if MSE is detected in two categories

Anti Virus and Spyware.

If it is not, that is the problem, I would uninstall MSE and try the MSE installer in administrator mode to install it again.

enter image description here

share|improve this answer

Security Essentials turns off Windows Defender, so I have been getting that message. Windows Defender won't run.

I disabled all the messages in Action Center, but it didn't help. I checked System Configuration, Startup, and it's not listed there. But there was a Windows Defender Service. I disabled that. No Change.

Finally, I found Windows Defender listed in System Information, System Summary, Software Environment, Startup Programs, with a -hide flag:

Windows Defender    %programfiles%\windows defender\msascui.exe -hide    Public    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

I killed that key in the registry and that solved the program. The hide flag must be why it didn't show up in System Configuration and msconfig startup.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.