Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to use NetworkManager to connect to my university's VPN, but it didn't work. Then I used a command line vpnc:

> sudo vpnc
[sudo] password for kirill: 
Enter IPSec gateway address: vpn.net.**.edu
Enter IPSec ID for vpn.net.**.edu: **
Enter IPSec secret for **@vpn.net.**.edu: 
Enter username for vpn.net.**.edu: **
Enter password for **@vpn.net.**.edu: 
vpnc: Error binding to source port. Try '--local-port 0'
Failed to bind to 0.0.0.0:500: Address already in use

Then I did

sudo vpnc --local-port 0

with the same configuration, and it all worked.

I'd like to be able to use the NetworkManager GUI to connect to VPN. I wanted to find out which program uses port 500:

> sudo netstat -a |grep 500
tcp        0      0 *:17500                 *:*                     LISTEN     
udp        0      0 *:4500                  *:*                                
udp        0      0 *:17500                 *:*                                
unix  3      [ ]         STREAM     CONNECTED     63500    
unix  3      [ ]         STREAM     CONNECTED     12500    @/tmp/.X11-unix/X0

There is nothing that uses 50.

I'm using Ubuntu 10.10 on a ThinkPad X201.

share|improve this question

UDP port 500 is used by ISAKMP, the IPsec key exchange protocol.

If netstat does not list the port as in use, try vpnc again after waiting a minute or so.

share|improve this answer

This just happened to me;

in my case reason was another vpn client installed (Shrew Soft Ike) and auto-starting at start-up.

Try to catch if some other vpn client is running (in my case, ps -e | grep ike), kill it and configure it to start only when required.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .