Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to open Gmail/Facebook/Hotmail on Firefox/IE on Widows 7 Home. I just unboxed a brand new hp laptop with Norton Security Suite running inside. I get following error message on Firefox. Please help.

The connection has timed out

The server at is taking too long to respond.

*   The site could be temporarily unavailable or too busy. Try again in a few

*   If you are unable to load any pages, check your computer's network

*   If your computer or network is protected by a firewall or proxy, make sure
      that Firefox is permitted to access the Web
share|improve this question

migrated from Feb 13 '11 at 13:09

This question came from our site for professional and enthusiast programmers.

is it only for these 3 sites??? that error suggests that there was no internet connection and nothing else.. that's the standard error. – ayush Feb 13 '11 at 7:08
1) Is it only for these 3 sites? 2) Have you tried disabling the firewall that comes with Norton Security Suite? – Cody Gray Feb 13 '11 at 7:15
This should go to SuperUser. – D_N Feb 13 '11 at 8:21

I figured out the solution. I am not sure about the generality of the solution but it worked for me at least. Uninstall firefox and re-install it but this time you will not import any settings from IE. That's it. It worked for me like a charm.


share|improve this answer
Sounds like you have IE set up to use a proxy server, then. If Firefox is importing that setting, it won't work either. Check your Internet Options (from IE, Tools->Internet Options). – Cody Gray Feb 13 '11 at 7:22
Yeah, IE was using a proxy server and the same proxy server is being used by the fresh install of firefox because it is the only way for me to get to the internet. Perhaps IE doesn't like other browsers too to open gmail. :) – singlepoint Feb 13 '11 at 7:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.