Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From time to time, OS X (10.6) will ask me if I want to perform a backup of my Macintosh HD, but the backup destination is obviously the HD itself. I have not plugged in any external device, nor is there a Time Capsule network share.

A message like this will appear: enter image description here

Moreover, the Macintosh HD will suddenly have a Time Machine icon in Finder. Has somebody experienced the same and could help me identify how to stop OS X from using its own disk as the backup destination?

share|improve this question
1  
This is saying that it can't find the Time Machine disk - it is not saying backuo to itself –  Mark Feb 13 '11 at 21:45
    
No, it is not saying that it can't find the disk. What you are referring to is another dialog. I am implying it backups to itself because there is no other disk plugged in and the Macintosh HD will get a Time Machine icon in the Finder. –  slhck Feb 13 '11 at 22:21

2 Answers 2

up vote 2 down vote accepted

Does your boot disk have any of the markings of a Time Machine backup disk? Do an ls -l /, and look for: "Backups.backupdb", files starting with ".blockFVBackupVolumeUnmount", or files named with just a "." followed by 12 hex digits (i.e. an ethernet hardware address). I'm not sure precisely how TM identifies its backup disks, but if one of these got created on your boot volume (or copied from your actual backup disk), it might explain why TM gets confused.

share|improve this answer
    
This is exactly it. I found a Backups.backupdb file. Thank you very much. However, I can't delete the file: rm: /Backups.backupdb/effloresce/: Operation not permitted (I am using sudo) –  slhck Feb 14 '11 at 20:21
    
I'd check inside the mystery folder a bit before deleting it -- see if you can figure out what happened. Is it possible your computer actually has been backing up to itself? As for deleting it, I don't have my backup disk handy to check, but I believe TM sets some special permissions (via ACL) and/or flags on its backups to keep them from getting messed up. Use ls -leO to display both flags and ACLs, then you can use sudo chflags no<flagname> /Backups.backupdb and sudo chmod -RN /Backups.backupdb to remove them. –  Gordon Davisson Feb 14 '11 at 21:29

Go to:

  1. System Preferences
  2. Time Machine
  3. Click the lock to make changes (make sure it is unlocked)
  4. Move the slider to the OFF position.
  5. Click the lock to make changes permanent (make sure it is locked)
  6. Close the window.
share|improve this answer
    
The point of Time Machine is making backups to my external drive, so I'd rather not turn it off. –  slhck Feb 13 '11 at 21:06
    
@slhck: Is there any problem in just clicking "Don't Back Up"? That's why the option is there... –  aqua Feb 13 '11 at 21:12
    
@slhck: Also when you remove your backup disk do you just unplug it or do you "Eject" then unplug it. If you're not properly removing it OS X Time Machine may get confused and think it still has to backup to something. –  aqua Feb 13 '11 at 21:16
    
No, I eject and then unplug as usual. I know that I can just click the button :) But this is obviously an error as you normally can't configure OS X to backup to its own HDD. –  slhck Feb 13 '11 at 21:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.