Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I reinstalled League of Legends because the patcher always gave me an error. However, out of complete stupidness I didn't uninstall the old installation first because I thought that it would simply replace the files. However, when the installer bar got to 100% it simply minimized. Then I closed the application from the task manager. I tried uninstalling it after a failed attempt to start it up. The same behavior as when I installed it. Then I tried reinstalling where it simply presented the InstallShield Modify/Repair/Remove menu and I selected repair. Nothing happened.

Then I tried selecting Modify, then seeing that the only option (called DefaultFeature) was unchecked. Same behaviour as install/uninstall. After seeing that it still failed, I uninstalled again. And after that I deleted C:\Program Files (x86)\League of Legends manually. When I tried installing LoL again it still thought I had it, so I chose repair. This time something actually happened, but it installed the whole game to C:\Windows. Seeing what was going on I clicked cancel and then started it up to try uninstalling it. However, I got an error message about something not being registered and then the minimization to I decided to let it repair completely. Then I uninstalled it and it gave only the minimization.

However, when I rebooted another application started up complaining about some library being absent. So I decided to do a system restore. After letting it complete I got a BSOD (0x0000006B(0x00000000, 0x00000000, 0x00000000, 0x00000000)) every time I tried starting up Windows normally or in safe mode. However, system recovery mode works, although the system recovery automatic repair does not fix it. After a bit of searching I found a Microsoft KB article about it (981833) and tried following the workaround instructions. Nothing happened.

I am using Windows 7 Home Premium 64-bit HP OEM and Ubuntu 10.04 LTS 64-bit installed with WUBI.

share|improve this question
    
Did you try another restore, pick another restore point? – Moab Feb 14 '11 at 1:54
    
@Moab Yes, but all the restore points disappeared. – Teo Klestrup Röijezon Feb 14 '11 at 14:16

If you can't boot, it sounds like you need a system repair.

  1. Get any Windows 7 disk.
  2. Reboot while tapping F2.
  3. Go into BIOS settings, and set your CD/DVD as first boot-able device.
  4. Insert the Windows 7 disk into the drive.
  5. Reboot.
  6. Follow these instructions. "Recover Windows 7 from a serious error". Do not choose Install!
  7. Choose REPAIR. This will not alter the program entries in the registry. You won't have to reinstall all your programs. It simply re-writes any original Windows system files.
  8. You will be asked for user name and password, to access the drive.
  9. Once REPAIR is done, reboot and do a check disk with /fix. This will repair any file, directory, or index problems.
  10. After this, delete the game's directory.
  11. Reboot.
  12. Then, download a Windows 7 registry cleaner, and clean it thoroughly. It will remove references to the uninstalled game.
  13. Reboot.
  14. Reinstall the game.

I wish you well.

share|improve this answer
    
Sadly, I can't do this, since I only have the on-hdd hp restore, which only lets me do a complete restore – Teo Klestrup Röijezon Feb 14 '11 at 14:19
up vote 0 down vote accepted

I finally decided to just go with the reformat option.
Thanks for all the help.

share|improve this answer

I had the same issue. After 5 and a half hours trying everything, the only end solution was to wipe and reformat the drive and upgrade windows

share|improve this answer
    
This does not add any real significant information. Resorting to a format isn't really a solution to the author's problem, its a solution and might be the only solution, but this answer itself at best a comment. – Ramhound Jun 17 at 17:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .