Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to specify VNC port number in built-in VNC client of Mac OS X?

I'm trying to connect to Xen VPS machine with Finder's built-in VNC client. I used address like this.


But it fails because it uses another port, and Finder's built-in VNC cannot handle port number. As I know it handles the number after colon as display-number, not a port number. Is there a way to specify port number on the VNC client?

Or any workaround for this? (port forwarding??? I have no idea about it...)

share|improve this question

4 Answers 4

Open a terminal window and type in:

open vnc://server:5900

Or try 5901 if it is on that port number.

share|improve this answer

A VNC display number is just another way of specifying a port. Display 0 is, by convention, port 5900; display 1 port 5901 and so on, so if the port your server is using is close to 5900, you can simply subtract 5900 and use that as the display number.

Contrary to what you say, Mac OS X's screen sharing client does accept port numbers with a vnc://server:port url. Either use open from the terminal as Michael Dillon suggests, or select "Connect to Server..." from the Finder's "Go" menu, and type the address in.

Finally if that won't work, it may be that your VNC client and server are incompatible - the Mac OS X VNC server is certainly a bit idiosyncratic. Try downloading a different VNC client such as Chicken of the VNC. If that doesn't work, you'll know that it's not client issues and could be something like a firewall getting in your way.

share|improve this answer

I cant find Chicken of the VNC but found Vine VNC server for OSX and that solved my problems with the built in OS X VNC server.

share|improve this answer
Can you describe the linked content, and how it relates to the question? This will help ensure that this answer remains useful in the event the link becomes invalid. In addition, please be careful posting links in answers of this nature--they could be seen by the community as spam, correctly or otherwise. See the FAQ for more information. – bwDraco Oct 11 '12 at 4:49

Whether or not you are able to connect to the port you wish may depend on your router configuration. You may need to configure some port forwarding from the NAT settings of your router. E.g. if your router has a public IP address, say, but your computer has a local IP address only (e.g. 192.168.x.x or similar, depending on your ISP) you need to forward port 5900 of your router to port 5900 of your computer so that any incoming request on port 5900 of your router is forwarded onto port 5900 of your computer. How to do this depends on your router and internet configuration, but look for some advanced setting under the NAT configuration. I just did it for me, successfully. Both using open vnc://server:port from terminal or Finder > Connect to server > vnc://server:port work fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.