Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing VMware Workstation on a SLED 11 SP1, and the installation is blocked by an error message "Kernel headers for version were not found". If you installed them in a non-default path you can specify the path below. Otherwise refer to your distribution's documentation for installation instructions and click Refresh to search again in default locations.

The output of rpm -qa | grep kernel is


I had met this issue in Ubuntu and I installed the required linux header via apt-get then the issue disappeared. But in SLED, I didn't find the rpm package in SUSE's software repository, and I also google "linux-kernel-headers-" but did not match any documents.

Any suggestion will be highly appreciated. Thanks.

The output result of zypper se kernel | grep kernel is

i | linux-kernel-headers | Linux Kernel Headers                                            | package   
  | linux-kernel-headers | Linux Kernel Headers                                            | srcpackage
share|improve this question

The kernel-header error is misleading - you have to install kernel-source. (After you do that, you might have to update the kernel itself, so check that afterwards.)

share|improve this answer
Actually isn't it kernel-devel? – Simon Sheehan Feb 21 '12 at 22:12
Well, where I saw the issue discussed, it said to install kernel-source, and that worked. one of the places: one vmtools discussion I can't speak to kernel-devel. Color me clueless. – Karla B Feb 23 '12 at 18:01
also [here] (…) – Karla B Feb 23 '12 at 18:09

You can use:

yast2 -i kernel-source
share|improve this answer
OP just wants the headers, presumably (I'm not familiar with SUSE) the command is yast2 -i kernel-headers-x.x.x.x (including the version is critical, otherwise they just get the latest). – vonbrand Mar 4 '14 at 13:03

Can you provide output result from zypper se kernel | grep header

Problem here is that your SUSE installed kernel headers is linux-kernel-headers-2.6.32-1.4.13 which doesn't match your current kernel

First, uninstalling package linux-kernel-headers-2.6.32-1.4.13 #rpm -e linux-kernel-headers-2.6.32-1.4.13

Update repositories with #zypper ref

Check for kernel headers package Version, #zypper if linux-kernel-headers | grep Version

if it match, so just go ahead.

Hope this help,

share|improve this answer
sudo zypper if linux-kernel-headers | grep Version Version: 2.6.32-1.4.13 it doesn't match, it looks like I should downgrade the kernel to 2.6.32-1.4, right? – Landy Feb 14 '11 at 6:59
I tried to use "zypper udpate linux-kernel-headers" to update the headers, but got "No update candidate for 'linux-kernel-headers'." – Landy Feb 14 '11 at 7:05

This worked for me:

cd /lib/modules/`uname -r`/build/include
ln -s   generated/uapi/linux/ .

Apparently version.h is not quite where VMWare expects it. VMWare finds it via the softlink.

share|improve this answer

With Opensuse 12.3, I had to run it has a root user.

I right click on the start button ( like if it were the Windows Start Menu ) then clicked "Edit Applications and under Systems > More Programs Selected VMware Workstation then went to "Advance"tab and checked the box run as a different user and wrote root.

Then do this on a terminal [CODE] cd /lib/modules/uname -r/build/include ln -s generated/uapi/linux/ [/CODE]

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.