Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new MacBook Pro with the high-res screen (1680x1050), but I noticed that all text is so small that to read it my face has to be like 18 inches away. When I adjusted the resolution to be the next sizes down (1440 x 852, and 1440 x 852 stretched), as well as all the other smaller sizes it made everything look blurry (similarly to when you use Command + Scroll to zoom in, how the text is really soft on the edges, and difficult to read). Is there a setting somewhere that I'm missing, or another resolution settings area that I can use. I feel like this 2800 dollar notebook may be only good for movie watching otherwise. Thanks in advance.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

This is a problem inherent to LCDs. Each pixel displayed corresponds to a physical pixel on the display. If you set the screen to any resolution other than its default, then it has to "guess" about what to do, because you might have 1 pixel trying to display over 1.5 physical pixels. This is why it looks blurry - you no longer have a 1:1 ratio of the pixels being displayed to the physical pixels.

If you want everything to be bigger, you have two options. One is to see if it's not too late to exchange your new laptop for the same model but with the lower-resolution option; I believe 1440x900 is the default resolution for the 15" MBP.

Your other option is to adjust the DPI of your operating system. DPI (dots per inch) is the measure of how large objects appear on the screen. Increasing the DPI will cause UI elements, text, etc. to appear bigger, though photos, etc. will remain the same size. This is still somewhat buggy in OS X, but there is another question on Super User covering how to do this; see change DPI on OS X.

share|improve this answer
    
AHHHH! I was afraid of this. It's not too late for me to replace it. Thanks for the quick answer. Now I have a decision to make :( –  orokusaki Feb 14 '11 at 7:20

You can usually enable zooming of some sort in all content-displaying applications.

  • Safari (Preferences » Advanced),
  • Apple Mail (Preferences » Fonts and Colors),
  • TextEdit (Preferences),
  • other text editors (in their respective preferences),
  • Preview (use regular zoom functionality, Cmd-Plus, Cmd-R),
  • Pages (Cmd->),
  • Keynote (Cmd->)
  • etc.

You will still have to live with the default font sizes in other user interface elements, but there's usually not a lot to read anyway.

Mac OS X's interface scaling functionality isn't really advanced enough for serious use, unfortunately.

share|improve this answer
    
Thanks. It's a tough decision for sure. I like the idea having a high-res screen for things that require it, but I can't help but think now that there aren't many of those times. I lower resolution may serve more utility (and keep me from going blind), and having to zoom in all all applications / set huge text sizes to compensate tells me that it's definitely a problem. –  orokusaki Feb 14 '11 at 14:33
    
@orokusaki I like being able to have a rather small UI element and text size by default (multitasking, better overview) and being able to selectively enlarge parts when I'm reading more than one or two paragraphs. I don't know about your eyesight issues, and ultimately it's up to you of course. Although 18 inches is further from the display than I'm used to, I believe. –  Daniel Beck Feb 14 '11 at 15:26
    
day 2 of the saga - I'm still thinking about it. I've updated my Komodo Edit settings to use 15pt font (which looks like aprox 12pt on a normal res) and it's not so bad. I also updated the terminal to use 13pt (vs 12 yesterday). You can't globally adjust font sizes in Firefox (though I do recall an add-on which allows you to add CSS/JavaScript into a box much like Firebug or Web Developer, but it stays for all pages. I can't remember the name). If I can solve Firefox, and a couple other things I do commonly, I tend to agree with your assertions about workspace trade offs, etc. –  orokusaki Feb 15 '11 at 5:42
    
@orokusaki font.minimum-size.western in about:config did it for me. –  Daniel Beck Feb 15 '11 at 5:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.