Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Toshiba Satellite L300-13R is refusing to connect to my Thomson TG585 V8 router.

The laptop is running up-to-date Vista and the router is using WPA-PSK encryption.

I have tried WEP, WPA, WAP2, WPA+WPA2 and unsecure settings on the router aswell as a few different channels. My windows 7 laptop is connecting fine, as is my Xbox360, DsiXL, Sony Ericsson W995 and a Vista laptop that I borrowed to test.

My vista laptop will connect to other routers including an N+ router. The Thomson is 802.1b/g/n and the laptop used 802.1b/g. I have added the DhcpConnEnableBcastFlagToggle to the registry (As found here - http://support.microsoft.com/kb/928233). I have also tried the ipconfig/rel command in DOS.

Still no connection to the router. Every time I try to connect it simply says 'taking longer than usual to respond' and fails. When I click the diagnose option then it says 'failed due to and unknown error'.

Anyone got any suggestions?

Edit: Is there some way I could get the settings off the vista laptop that connects and use them? Or is this most likley a hardware issue?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I had this problem with a Toshiba laptop when trying to connect to a Wireless N router. I feel the issue is related to the Atheos (I think thats how you spell it) Wireless card on the laptops. I tried everything from reinstalling the drivers to checking all the settings as mentioned.

In the end, the only way it started working by was doing a full reinstall of Vista. I would suggest this as a last resort. It does solve the problem though.

share|improve this answer
    
If it came to that I think I might try windows 7 and speed up the machine in the process. I've had the laptop connected to an N+ router in recent weeks and there was no issue there. Why would there be an issue with a N router(and a weak one at that, only 1 antena)? –  kidd Feb 15 '11 at 10:03
    
I have no idea, that's what frustrated me. Thing is the laptop ran Vista Home Premium when the problem occurred, and then I installed Vista Business with the latest service pack and it has worked fine ever since, even on the router it couldn't connect to. That might be one thing to try before doing a full reinstall, make sure the service packs are up to date. If it still doesn't work then wipe it. –  mickburkejnr Feb 15 '11 at 10:52
    
I'm running home premium on it at the minute. As far as I'm aware it's all up to date, but I'll check for sure. –  kidd Feb 15 '11 at 11:04
    
Just Googled your laptop model, and it's identical to the one I had this issue with. –  mickburkejnr Feb 15 '11 at 12:30
    
Thanks. I'll check it's updates and if it's up to date I'll look for the vista you used and a version of windows 7 for it. See what works then. –  kidd Feb 15 '11 at 12:46
  • Check if dhcp is enable on your router,
    • Check if the range of dhcp settings is not full
    • Check if mac filtering is not enable on your router
    • Check if dhcp is enable on your laptop

Finally, you can try to setup a fixed ip address on your laptop, or test connexion using an ethernet cable.

And if nothing works, upgrade your vista to seven ??

share|improve this answer
    
Definitely check whether you've got MAC filtering enabled. This got me recently. –  ChrisF Feb 14 '11 at 9:57
    
I'm not in front of the laptop now, but how do I go about checking if DHCP is enabled on it? And what does connecting by ethernet test? The network is working. –  kidd Feb 14 '11 at 10:02
    
On windows XP, there is a service called 'DHCP client', it must be started. (Control panel > Admin tools > Services). Path should not be different in Vista ?! –  Janfy Feb 14 '11 at 10:44
    
@Janify I'll check that out when I get home. Is there a chance this could be a hardware issue? Such as the network card and the router just not working together? I might look for windows 7 for it if it's not a hardware issue. –  kidd Feb 14 '11 at 12:16
    
I spent some time looking at this last night and I don't see anything relating to mac filtering, or dhcp range. dhcp is enabled on both the router and the laptop. It connects via ethernet fine tho. –  kidd Feb 15 '11 at 8:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.