Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought it about 5 years ago and it came bundled with Windows Vista.

When Windows 7 launched, I waited a bit then realized it would rock with an SSD.

So I bought an SSD and added it as my primary SATA drive (set in BIOS) then installed Windows 7 from the CD I bought.

I didn't wipe my old HD and kept it as D:\ cos I needed all the data off it. I thought this was a good idea at the time, but during boot now I get two options for boot

  1. Windows 7 on C:\

  2. Windows Vista on D:\

Weird, but I lived with it for as everything was sweet for 5 years...

So now years later I've finally got around to migrating all the data off it and onto a NAS... and I wanted to get rid of the old HDD.

But when I just unplug the old HDD (power and data)... my BIOS complains it has no drive to boot off of.

What's the deal?

How do I delete this old HDD?

I'm afraid of just formatting it cos if it has a boot sector that's needed I won't be able to boot this machine (which I need for work).

Does anyone have any ideas or advice?

UPDATE: I discovered my HDs weren't in the correct boot order. I corrected the boot order of the hard drives in BIOS, but still get the same problem.

Also, thejourneymans suggestion didn't work after a corrected boot order.

share|improve this question
    
did you try to fix the mbr using my solution? –  g19fanatic Mar 2 '11 at 12:54

3 Answers 3

up vote 6 down vote accepted

When you pop in your windows 7 dvd and enter recovery mode.

You will want to run the following cmd on the cli:

fdisk /mbr

That will fix the 'master boot record' of the current drive and will make it bootable according to windows standards.

share|improve this answer

Chances are that the boot sector is on the drive. Pop that drive out, pop in your windows 7 DVD or recovery disk, and select system recovery, and the startup repair mode to fix it. If that works, then you can nuke the old hard drive

share|improve this answer
    
Thanks for your answer... but that didn't work :( I've added more info into an edit if that guides you to a different answer perhaps? –  CVertex Feb 17 '11 at 8:20

My first answer would be a bios setting. Go into the Bios and change the boot options. It is most likely one of the below settings.

  1. It is set to IDE or mixed mode and thinks there are no drives anymore since it can't find the IDE drive. If this is the case you need to change it to SATA mode or equivalent setting in your BIOS.

  2. You may need to set the BIOS to not look for whichever slot it was plugged into.

  3. Perhaps it is just your boot order. Sometimes pulling drives out can mess that up and it is now looking to boot from something completely wrong.

  4. If it isn't a BIOS setting, then doing the fix mbr should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.