Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem with Windows 7 Professional when I am try to access to a network shared folder.

I have a two personal computers:
- pc (A) with Windows 7 Professional, user logged with Administrator rights,
- pc (B) with Windows XP Professional.
In (B) I share a folder (c:\foo).
By (A) and Windows Explorer I map the shared folder in (B), I give the correct User and password for the folder access and I map it with a letter (i.e. Z:)
Now, with Windows Explorer I can access the folder Z: without problem; if I open CMD and I write

Z: + return


at prompt I can access to the network folder but if I do the same action executing CMD with Administrator rights the command Z: + return give me this error:

The system cannot find the drive specified.


I don't understand where is the problem ...

share|improve this question
    
Try to re-map the drive within the new cmd window (with "net use"). I guess the mappings are not the same when running in admin vs. non-admin mode. –  CyberDude Feb 14 '11 at 16:11
    
There is a registry fix for it: support.microsoft.com/kb/937624 –  rafraf Mar 14 '12 at 6:12

2 Answers 2

up vote 3 down vote accepted

This is a Windows 7 Gotcha : An administrator cannot access network shares created by a non-administrator.

The solution is to create the share using an Explorer that was also "Run as administrator".

See this article : Mapped Network Drives with UAC on Windows Vista.

share|improve this answer
    
Wow, thank you, I did not know this. Do you have a source? I would really be interested in reading more about why this is the case –  Kyle Feb 14 '11 at 16:45
    
I added above the link to the blog entry. –  harrymc Feb 14 '11 at 16:56
    
Thank you very much :) –  Kyle Feb 14 '11 at 17:13
    
Thank you Kyle, it seems works. A strange behavior but I have to accept it :-) –  maxim Feb 15 '11 at 7:40
    
@maxim: If this is the right answer to your question, you should mark it as accepted, to clarify this for future visitors. –  harrymc Feb 15 '11 at 8:37

http://windows.microsoft.com/en-US/windows-vista/Enable-file-and-printer-sharing

Enable file and printer sharing

Make sure network discovery and printer sharing are on by following these steps:

1.

  Open Network and Sharing Center by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Network and Internet, and then clicking Network and Sharing Center.

2.

  If network discovery is off, click the arrow button Picture of the arrow button to expand the section, click Turn on network discovery, and then click Apply. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

3.

  If file sharing is off, click the arrow button Picture of the arrow button to expand the section, click Turn on file sharing, and then click Apply. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

4.

  If Public folder sharing is off and you want to share files by placing them in the Public folder on your computer, click the arrow button Picture of the arrow button to expand the section, click Turn on sharing so anyone with network access can open files or Turn on sharing so anyone with network access can open, change, and create files, and then click Apply. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

5.

  If printer sharing is off, and you have a printer you want to share, click the arrow button Picture of the arrow button to expand the section, click Turn on printer sharing, and then click Apply. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

6.

  Finally, share the file or printer by doing one of the following:
      *

        Right-click the file or folder you want to share, click Share, click the arrow, select the people you want to share with, and then click Share. For more information, see Share files with someone.
      *

        Copy the files or folders you want to share to the Public folder on your computer. To find the Public folder, click the Start button Picture of the Start button , and then click Documents. In the Navigation pane, under Favorite Links, click Public. For more information, see Sharing files with the Public folder.
      *

        To share a printer, see Share a printer.

If you're still having trouble sharing files or a printer on a network, make sure Windows Firewall is not blocking File and Printer Sharing. Here's how:

1.

  Open Windows Firewall by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Security, and then clicking Windows Firewall.

2.

  Click Allow a program through Windows Firewall. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

3.

  In the Program or port list, make sure the File and Printer Sharing check box is selected, and then click OK.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.