Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Title's pretty explanatory. I have an application(Second Life) that isn't compatible with 64-bit windows 7. It says that it is compatible with Windows XP, Vista, and 7 but only the 32-bit version of 7. I need to know if it's possible for me to download something to make the application compatible with my computer. I've run troubleshooters and ran it as windows compatible XP service pack 2 and tried again with service pack 3.

share|improve this question
    
Links would be appreciated greatly. –  Glenn Feb 14 '11 at 21:54
    
Is it a 16-bit application? Native 32-bit applications are generally emulated properly under 64-bit Windows. Maybe there's something else going on with a driver or library incompatibility...can you be more specific about what you're trying to run? (There's not a one-size-fits-all answer ANYWAY so you'll need to provide better details.) –  Shinrai Feb 14 '11 at 21:57
    
I agree with @Shinrai, the question needs updated with some more details. –  afrazier Feb 14 '11 at 22:01
    
It's called Second Life, and it says that it's compatible for Windows XP, Windows Vista, and Windows 7(32-bit only). That's about the extent of my information. –  Glenn Feb 14 '11 at 22:03
    
I assume you mean this - secondlife.com –  ChrisF Feb 14 '11 at 22:07

7 Answers 7

I used the Longbow Reviver (www.longbowsoftware.com/Reviver.php) tool to fix my various compatibility issues on my Windows 7, then now on my Windows 8. I had some really old 32bit driver issues... Worked well for me.

Tom

share|improve this answer

I have run SecondLife on Win 7 x64 without issue in one of our teaching labs. The only thing I needed to do was to install the graphics card specific driver rather than the Windows 7 install default version.

Your question caught me by surprise as all I did was download and install it, didn't do any magic to get it working.

share|improve this answer

Others have mentioned XP Mode, which -- when properly capitalized -- refers to a copy of "real" XP run inside a more-tightly integrated Virtual PC. It requires Windows 7 Professional, Ultimate, or Enterprise.

EDIT: this tighter integration is achieved by displaying the XP session through Remote Desktop, which is limited to 16-bit color by default. If you need more, you can try enabling more color depth by following these steps. Or you can try disabling the Integration Features.

share|improve this answer
    
Yeah, I was thinking of something else; Right now i've installed XP mode and am re-installing my application in that mode. –  Glenn Feb 14 '11 at 22:39
    
Well, it almost worked, but in XP mode but it only runs in 16 bit and the application requires 32 bit true color... –  Glenn Feb 14 '11 at 22:45
    
@Glenn - Change the video settings (Properties if you right-click on the desktop). That's a different bit rate it's talking about, the color depth. –  Shinrai Feb 14 '11 at 23:27
    
Added links for getting more color depth. –  Ken Feb 14 '11 at 23:40
    
Ooh, I didn't realize they didn't have a workaround for 32-bit color by default. Good to know, thanks! –  Shinrai Feb 15 '11 at 0:05

That 32bit program might have some 16bit code, as W7 64bit does not support this. If you have W7 Pro or Ultimate you can install XP mode and run it on XP inside of W7

http://www.microsoft.com/windows/virtual-pc/download.aspx

Otherwise you will have to run other Virtual OS software to run XP inside of W7.

share|improve this answer
    
It must not be 16 bit, because i just got an error message saying that it needs 32-bit true color... –  Glenn Feb 14 '11 at 22:46
1  
There could be 16 bit code in the program. 32bit true color has to do with graphics, not the program code itself. –  Moab Feb 14 '11 at 23:05

Um, i've run second life in 64-bit windows 7. Perhaps you need a newer copy of the game, or to update your video drivers?

share|improve this answer

The system requirements page states the following in the Linux section:

If you are running a 64-bit Linux distribution then you will need its 32-bit compatibility environment installed.

NOTE I'm not suggesting you switch to Linix, but that there there might be a way to get it working if you can use a 32 bit environment somehow.

I've also found this on a page giving detailed information about SL compatible systems

At some point while scouring the web for more information about this problem I saw a message that indicated that all 32-bit OpenGL apps were failing under Windows XP x64 on the 8800 series boards.

It could be that the limitation is due to the OpenGL implementations. The page goes on to give a workaround that involves copying the drivers manually into C:\WINDOWS\SysWOW64, plus the usual caveat about being careful.

share|improve this answer
    
I'm running windows and i don't have a linux OS to use. –  Glenn Feb 14 '11 at 22:14
    
@Glenn - I wasn't suggesting that you use Linux - just that there might be a way to get it to work as it does run under one 64 bit OS. –  ChrisF Feb 14 '11 at 22:17
    
okay, well interesting thought, i wouldn't really begin to understand how to do that though. –  Glenn Feb 14 '11 at 22:18

Although I have not personally installed this program, I do not see any reason a 32 bit Windows 7 program will not run on 64 bit Windows 7 (I'm sure there are certain exceptions to this). I have run numerous programs that do not state having 64 bit compatibility on Windows 7 64 bit. If there is an issue you can always run it in XP mode.

share|improve this answer
    
If by XP mode you mean using windows compatibility mode to run it as windows XP i've done it with both service pack 2 and 3. Still hasn't worked. –  Glenn Feb 14 '11 at 22:15
    
@Glenn - No, I think Kyle means XP Mode. windows.microsoft.com/en-US/windows7/products/features/… –  Shinrai Feb 14 '11 at 22:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.