Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an application/game that ran smoothly a few months ago but lately I've realized it runs more sluggish than usual (the frames per second get quite low).

I thought maybe something I installed is causing this application to lag so I terminated all unnecessary processes (including explorer.exe) leaving only the core processes. I even shut down any non-essential services. Other thing I turned off was my antivirus so my OS shouldn't have any unnecessary tasks running in the background at this point.

When I loaded the game, it still had a fairly low FPS.

Knowing that I have not made any hardware changes since that time, and wondering why the game still ran slowly with all available resources, the next thing I tried was to setup another partition with a fresh copy of Windows 7. I then reinstalled the game on that partition and surprisingly it ran smoothly like it did a year ago.

Switching between the two partitions, I can tell a big difference between the FPS of the game, even when I run my "Kill_Unnessessary_Processes.bat". I've even noticed my browser loading and scrolling webpages and flash videos faster.

The only difference between the two partitions at this point is that the old partition has a lot more programs installed but are inactive. Which leads me to my question, when considering "software bloat", does having a lot of programs installed on your hard drive slow it down overtime, even if it is not in running in memory?

I can think of two reasons why this might be: 1) it would take longer to lookup stuff in the registry and 2) I could have some rootkit that I don't know about quietly stealing my resources on the first partition.

I would like to hear about any other possibilities that could cause this. If at all possible, I would like to switch back to one partition.

share|improve this question
    
Does your batch file also gain you the FPS back on your slow partition? –  Tom Wijsman Feb 15 '11 at 0:15
    
No, it doesn't. –  Steve Feb 15 '11 at 0:25
    
Do you get the same result when you run the program from a new user instead of a new Windows installation? –  bastibe Feb 15 '11 at 7:49
add comment

4 Answers 4

does having a lot of programs installed on your hard drive slow it down overtime, even if it is not in running in memory?

If you have a HDD, thus not a SSD, then fragmentation is the most likely cause of slowdown over time; any programs that are installed but are not said to load directly or indirectly into memory will not cause any other form of slowdown. You can determine what gets loaded in upon a boot with the AutoRuns tool from Microsoft Sysinternals. I feel like most likely there is something in here...

Other than that you can't assume

1) it would take longer to lookup stuff in the registry and 2) I could have some rootkit that I don't know about quietly stealing my resources on the first partition.

to be true without actually measuring it or scanning for it. The former is rarely a problem given that the registry is made up as a tree so it won't matter unless the registry really grows to abnormal sizes. As for the latter, just scan using the best rootkit and virus scanners you could find.

share|improve this answer
add comment

As Wil said, Autoruns is useful, but before you can start disabling things, you’ll need to know exactly what is causing the problem. For this, I would recommend Process Explorer (also from Sysinternals). Get that and take a look at what’s running.

Look at the CPU graph to see if it is at ~0% when idle. If not, make sure that the CPU History column is enabled and look to see which process is sucking cycles. If it’s one spawned by Explorer (make sure the display is in—the default—tree-mode), then try quitting the program (or killing it if there is no interface for doing so). If it is one of the various instances of SVCHOST.EXE or other items under SERVICES.EXE, double-click it and look in the Services tab, then try stopping the services in there, making sure to watch the CPU graph after each one.

You should now know what is causing the trouble (unless it is a shell extension in which case Explorer.exe itself will be using the CPU). Now you can exit the offending program/service/etc. when you want to play the game or block it from running in the first place, depending on how it is starting up. Now is the time to use Autoruns and/or ShellExView to turn it off. In either case, make sure to use the options that verify signatures and mark/hide Microsoft entries to make it easier to see what third-party (ie non-OS) items are installed.

share|improve this answer
add comment

Make sure you kill any running services which are likely to trigger any kind of disk activity. This is often the reason why you find your frame-per-second bleeding.

If you're a hardcore user, also try taking a look at TweakGuides for some good tips on how to optimize your system for some of the most popular games on the market.

share|improve this answer
    
There are quite useful services, such as the one that runs defragmentation every once in a while. It might indeed be the problem that this service is not running. –  bastibe Feb 15 '11 at 7:49
add comment

Have you tried a few older tricks such as defragging your hard drive?

Apart from this, the only thing I can think of is you either missed something when looking at applications (My favourite tool is Microsoft / Sysinternals Autoruns) or it is a driver update / automatic update of some program somewhere that is causing problems.

The registry thing is pretty much a myth as long as software has not interfered with crucial parts.

And no, a lot of programs will not slow down your computer, with the exception of a badly fragmented drive. If you are a moder/real power user, as you said you tweak services, just make sure you have not turned off crucial "maintenance tasks" which keep your machine at peak performance.

Lastly, check the Performance counters in Computer Management and see if they can give you any idea of when the problem started and what happened at that time.

share|improve this answer
    
Those are some nice tips. I've give defragging a try when I get home and try Autoruns. Thanks. –  Steve Feb 15 '11 at 0:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.