Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows Vista SP2 Home Premium 32-Bit, with a Lexmark X5450 All-In-One Printer.

Whenever I try to change the Print Spooler Service from Automatic/Manual/Disabled to Automatic (Delayed Start), I get the following error:

---------------------------
Services
---------------------------
The delayed auto-start flag could not be set.



Error 87: The parameter is incorrect.


---------------------------
OK   
---------------------------

And the Print Spooler Service doesn't change its Startup Type. Is there any way around this?

share|improve this question
    
What OS? Windows? –  Dennis Williamson Feb 15 '11 at 6:25
    
What are you using to make the change? Is it running as admin? You could check the registry to see if the Services\Spooler key, and particularly the RequiredPrivileges value is damaged. –  Synetech Feb 15 '11 at 6:25
    
@Dennis Windows Vista SP2 Home Premium –  muntoo Feb 15 '11 at 6:43
    
@Synetech Yeah, I'm admin, using services.msc. I'll try what you said... EDIT: What should the RequiredPrivileges value be? For me, it's SeTcbPrivilege SeImpersonatePrivilege SeAuditPrivilege SeChangeNotifyPrivilege SeLoadDriverPrivilege SeAssignPrimaryTokenPrivilege SeBackupPrivilege SeRestorePrivilege –  muntoo Feb 15 '11 at 6:45
1  
I just tried it myself using the Services MMC snap-in, the service-controller, and even manually setting it with the registry and none of them worked. I was able to set other services to delayed-auto and could set the spooler to other modes, but the spooler just does not want to be set to delayed-auto. o.O I’ll ask around to see if I can find any info on why it won’t… –  Synetech Feb 16 '11 at 1:42
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.