Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Linux and Windows 7 on the same machine and my on-board NIC is functional under both. However, the weirdest thing happens when I browse the internet under Linux and then return to Windows; my NIC stops being recognized! This happens under Windows but also in Linux when I return! This problem is then easily fixed by resetting the CMOS, but inevitably occurs again. Why does this happen?

Update The CMOS reset works but is not necessary for me. Shutting down and unplugging the power cord works as well.

share|improve this question
    
This is actually related to another question I have asked that may or may not provide some more background information. @ngen –  Usagi Feb 15 '11 at 7:58

2 Answers 2

up vote 1 down vote accepted

The driver under each OS is configuring the card in a manner that causes the driver under the other OS to not be able to recognize or handle the card properly. The solution is to fix one or both drivers, but that can be a challenge even when you do have the source for the driver.

share|improve this answer
    
Does this problem survive powering off the machine, or is the OP stuck with his CMOS workaround? I'm curious as to how the problem persists. –  user3463 Feb 15 '11 at 10:15
    
@Randolph The problem does persist after powering off the machine. I've tried doing this a couple times and waiting but the only thing that seems to work is a reset of the CMOS. –  Usagi Apr 11 '11 at 23:23
1  
@Randolph The CMOS reset is actually not necessary. I just tried shutting down and unplugging the power cord and that works as well. It's still not a satisfactory solution given that I will need to do this each time I switch OSs. –  Usagi May 2 '11 at 19:02
    
Interesting. I had this problem back in the day with internal modems. I'm surprised it's happening with a modern NIC. –  user3463 May 2 '11 at 22:05

I am having the same issue. So far the "best" solution I've found is to uninstall the network adapter using device manager, then scan for hardware changes which reinstalls it. At least this way you do not have to get up and unplug anything and restart the pc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.