Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have setup a shared folder on my Ubuntu “file server” (actually just an Ubuntu desktop) called "files" in "/home/tech1/Public/files". Also I have created a user group "PBW" that contains all the users and passwords. All the user's stations are Windows computers. Now from one user’s Windows station I copied a few test Word documents into the Umbuntu folder. But now from a different user’s Windows station I find the files are set to Read-only. Of course I can not change the file without saving it with a new name, and then the original user finds that to be a read-only file also. Only the maker can modify their own files. This appears to be normal, default linux behavior and I understand the logic of that.

However, our small office needs to allow all users to open and modify all other user’s documents and save them back to the original folder for others to access and modify. It is not feasible for each user to set chmod on each file and anyway, I don’t want the users to even know that their new file server is actually using Ubuntu. They only use Windows machines and have no interest in learning linux commands.

I think umask will help me do this by setting the shared folder to 000 but I don’t know how to perform this simple operation. How exactly do I go about opening the permissions on this one folder on my Ubuntu file server so that anyone and everyone can access anyone or everyone’s files and sub-folders?

I think I need to first modify FTAB and include the mount locations of my shared files. Also in FTAB I believe I will need to specify a list of user names and passwords that is stored in a master file .smbcredentials. Then I need to configure smb.conf.

Any guidance for this beginner would be appreciated.

share|improve this question

1 Answer 1

in smb.conf under section for your share, put:

valid users = @PBW
force group = PBW
create mask = 0660
directory mask = 0771
writable = yes

and restart samba

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.