Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using pam_mount to mount users' home directory upon successfully logging into the system. It works; however, the password prompt says:

pam_mount password:

Instead of just:

password:

How can I change it back to the original while keeping pam_mount?

Thanks,

Walter

share|improve this question
up vote 2 down vote accepted

Move pam_mount below pam_unix in the PAM stack.

share|improve this answer
    
Looks like that did it. – Walter White Apr 4 '11 at 1:07

From man pam_mount.conf:

Name

pam_mount.conf - Description of the pam_mount configuration file

Overview

The pam_mount configuration file defines soft defaults for commands pam_mount will be executing, the messages it will show, and which volumes to mount on login. Since pam_mount 0.18, the configuration file is written in XML so as to simplify the pam_mount code base while giving formatting freedom to the end-user. Special characters like <, > and & that are used by XML itself must be encoded as &lt;, &gt; and &amp;, respectively; additionally, " must be encoded as &quot; within a "" area, but these three/four symbols are unlikely to be seen often anyway.

. . .

Messages

<msg-authpw>pam_mount password:</msg-authpw>
When pam_mount is not used with "use_first_pass" or "try_first_pass" keywords in the PAM configuration files (/etc/pam.d/), it will have to ask for a password. This is also the case if pam_mount is the first auth module in the block. allows you to customize that prompt.

<msg-sessionpw>reenter...:</msg-sessionpw>
In case the 'session' PAM block does not have the password (e.g. on su from root to user), it will ask again. This prompt can also be customized.

share|improve this answer
    
Thanks for your reply, I found a single configuration file that did not have use_first_pass as an option for the auth part of the configuration. None of my session configurations have use_first_pass or try_first_pass. I will logout and login and see what happens. – Walter White Feb 17 '11 at 10:05
    
That was a no go, odd that it complained. I was missing that option in my system-auth configuration file. I returned it back to what it was previously configured as. – Walter White Feb 17 '11 at 10:11
    
The link is busted to the pam_mount.conf page you referenced. – slm Mar 21 '14 at 13:24
    
@sim: I replaced the link. – Dennis Williamson Mar 21 '14 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .