Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a homegroup set up, and only the accounts/machines where the user and password is identical can see/share files. I thought the setting to let homegroup control the accounts would make that requirement I missing something?

To be clear: I can see the other machines/user accounts in my homegroup listing, but I can't see any of the files in their shared libraries.

share|improve this question

I have to ask, have you actually shared any folders or files on your pc? You will only see the folders/files that you share. To share a particular folder do this: Open the folder, click on the 'File' menu, then 'Share with', then 'Homegroup'.

share|improve this answer
Hmm...your built-in library folders aren't shared automagically? I'll have to double check that. – Jonas Aug 27 '09 at 5:22
Ok, sorry about the delay, I've tried this, and it still doesn't work. Bummer... – Jonas Sep 5 '09 at 4:00

The following worked for me:

  1. Run the troubleshooters on all PCs in the network
  2. If that didn't work, exit the homegroups on all PCs
  3. Reboot
  4. Create a new homegroup
  5. Wait for the HG to show up on the other PCs
share|improve this answer

I was having somewhat of the same problems with the homegroup and network in Windows 7 64bit. What i did that helped was downloaded the upgrade firmware version for my router. After doing that and resetting it back up, everything seems to be running 100%. Try it, i hope it works for you guys. Also remember that your going to have to redo all the other computers even if the passward etc, are the same. Good luck

share|improve this answer

Try to enable the service: "TCP/IP NetBIOS Helper" on all machines. That did the trick for me..... And check that these services are running too: dnscache, fdrespub, ssdpsrv, and upnphost. Enjoy.....

share|improve this answer

fought this problem for 4 hours on a Win 7 desktop / laptop combo. I realized the computer names were identical, changed the desktop name (which was the author of the homegroup) and it instantly worked with no other changes.

Make sure your computer names are unique! Note: computer names are not case sensitive.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.