Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine with Office 2000 installed.

I am doing some development with Outlook Add-Ins and I installed Office 2010 Professional Plus. Development of this add-in is going fine.

My client may delay upgrading Office 2007 to Office 2010 so I would like to install Office 2007 alongside my current installation of Office 2010 and test my Add-In in the older environment.

I can configure Outlook 2007 to use a different email account than that used in Outlook 2010 (i.e. this is strictly for development testing; no need to share a .pst file between versions).

Is this possible - or must I un-install Office 2010 (Outlook 2010) in order to test with the older Office 2007?

share|improve this question

migrated from serverfault.com Feb 15 '11 at 19:32

This question came from our site for system and network administrators.

    
Isn't this more of a StackOverflow or SuperUser question? –  ChrisA Feb 15 '11 at 18:58

6 Answers 6

Trying to have things coexist, that aren't really 'supposed' to, for testing purposes, is at best inconvenient (because of all the messing around you often have to do), and at worst misleading (because it's sometimes not obvious that the messing you've had to do to achieve the coexistence, also changes the behaviour in some subtle way, that invalidates the test).

Been there, bought the t-shirt, experienced the pain.

Much better to virtualise - then you can have as many test environments as you like, all different, and each uncontaminated by the others.

share|improve this answer

Bad news my friend... Microsoft in the Article says it cannot be done with outlook 2010. Therefore you will need to setup a VM to test with.

Excerpt from the article:

Multiple versions of Outlook

Microsoft Office Outlook 2010 cannot coexist with any earlier version of Microsoft Outlook. When you install Outlook 2010, the Setup program removes Microsoft Office Outlook 2007, Microsoft Office Outlook 2003, and Microsoft Outlook 2002. The Setup program removes these versions of Outlook even if you click to select the Keep these programs check box in the Removing Previous Versions dialog box.

share|improve this answer

Because each Outlook version uses its own version of MAPI, you cannot install more than one version of Outlook on any machine. This is also true for anything else that requires MAPI components like BES or Exchange 2003. If you try to install Outlook on a machine with BES or Exchange 2003, you break something because of the MAPI version mismatch.

share|improve this answer

With Microsoft's App-V, many things like this are possible

share|improve this answer

My understanding is that everything can coexist except Outlook -- you have to pick one version of Outlook or the other.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.