Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the taskbar set to "Never group", so icons of multiple instances of the same program always appear directly next to each other. This set of icons always fills in the very order the instances are launched, i.e. if I open Notepad three times, the instance opened first is always the left icon, the second one the middle icon, the last one the right icon.

However, when an application seems to do heavy duty (for example Visual Studio loading a large solution), that instance's icon sometimes, seemingly randomly, gets positioned at the right side as if it were a new instance, even if it has been the very first one all the time.

This is highly irritating when you're working with those multiple instances and are used to their order, and sometimes you just end up in the wrong instances when clicking one of the icons - because one got put at the back of the list.

Does anyone know what's causing this? Is there a setting to prevent this from happening while keeping the "Never group" setup?

share|improve this question
    
Just so you know, I still have this issue. I've found since posting the question that it sometimes happens to an application instance which is currently very busy. However, it is still not consistent in behaviour and I cannot believe this is intended any way. –  Mephane Apr 11 '11 at 13:16

2 Answers 2

Yes, I see this in Windows 7, and no, I don't know why it happens. I think it occurs when my laptop wakes from sleep or when I connect/disconnect an external monitor, but I'm not entirely sure of that. Extremely annoying.

In the question below, someone suggests 7 Taskbar Tweaker , which looks like it would at least help get the order back to what you want it when it happens. Not sure it's worth it to me to run 3rd-party software for something that is only an occasional annoyance, though.

Arrange windows within the same application in the taskbar of Windows 7

share|improve this answer

Not quite sure of the cause, but have you tried locking the taskbar? Or is it locked and you still have the same issue?

share|improve this answer
    
The taskbar is locked. –  Mephane Feb 17 '11 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.