Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a system with a Windows drive and an Ubuntu drive (both physical, not virtual). The Ubuntu Places menu lists a "320 GB file system" which is the Windows disk.

The same drive also appears as an icon on the desktop, but unlike everything else on the desktop, it does not appear in the directory listing of ~/Desktop.

I think the icon was put on the desktop by accident and I never use it because the Places menu suffices. How can I delete this icon? Selecting then deleting does not work.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Hide all the volumes from desktop:

gconftool-2 --type bool --set /apps/nautilus/desktop/volumes_visible 'false'

Ripped from here. If you want to hide specific volume, follow the link, there is a solution.

share|improve this answer

Use gconf-editor to disable showing mounted volumes on desktop. Here is a video

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.