Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was able to disable file download popup in all popular browsers except Internet Explorer.

This is the popup:

File Download popup

I thought this would do it, but I still get the popup:

Internet Explorer > Tools > Internet Options > Security > select zone (example: Internet) > Security levels for this zone > Custom level... > Downloads > File download > Automatic prompting for file downloads > Disable > OK > Yes > OK.

I am not interested in automating the popup, I do not want it to appear.

OS is Windows 2003, Internet Explorer 8.

share|improve this question
1  
Let me begin by summarizing 3 methods that did NOT work: FIRST Internet Options > Security > Custom Level > uncheck Automatic Prompting for file Downloads SECOND Folder Options > File Types > Advance > Uncheck the check box for prompt on Download THIRD Registry > HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ Internet Settings\Zones\*\1803 > Change to 0 or 3 –  Seubei Jun 21 '11 at 7:18
1  
Your fix only disables Automatic Prompting for Downloads if the user did not initiate the download, i.e., if it was initiated from the webpage. See msdn.microsoft.com/en-us/library/dd565669%28v=vs.85%29.aspx –  kalaracey Jun 22 '11 at 15:37
1  
What do you want it to do when you click on a file URL, instead of prompting to download? Just download the file directly? –  Joshua Jun 23 '11 at 16:55
    
Yes, just download the file, like all other browsers do. –  Željko Filipin Jun 24 '11 at 13:21

3 Answers 3

Go to Start->Run->gpedit.msc

Double-click the “Turn off the Security Settings Check Feature” entry and choose “Enable enter image description here

Explanation: This policy setting turns off the Security Settings Check feature, which checks Internet Explorer security settings to determine when the settings put Internet Explorer at risk. ( NOTE: this means that the annoying bar will not pop up) NO MORE ANNOYING INFORMATION BAR!!! If you enable this policy setting, the security settings check will not be performed. If you disable or do not configure this policy setting, the security settings check will be performed.

Reghack if you don't want to do it via gpedit

Open regedit (Start > Run > regedit ) - Navigate to HKLM\Software\Policies\Microsoft\Internet Explorer\Security

  • If those key don't exist, you'll probably have to create them. They are case-sensitive.

  • Create the following DWORD (case sensitive) DisableSecuritySettingsCheck

  • Give this DWORD the value: 1

Source

share|improve this answer
1  
Thanks, I will try it, but it looks to me that you are talking about disabling information bar. I want to disable File Download popup. –  Željko Filipin Feb 16 '11 at 21:30
    
Oh, I thought you meant the info bar, sorry. Do you mean the dialog box?, Run, Save, Cancel? –  Moab Feb 16 '11 at 22:30
    
Yes, popup with the title "File download". (Take a look at the link in my question for screen shot.) I want to click a link to a file and have the file downloaded to my machine without any popups. –  Željko Filipin Feb 17 '11 at 7:57
    
I think you would need a download manager to do this, I know of no way to do it in windows IE natively. –  Moab Feb 17 '11 at 16:17
1  
Isn't that strange? :) I was able to disable the popup in all other browsers. –  Željko Filipin Feb 18 '11 at 9:08

I believe this SU question might be similar to yours

You can use the addon iMacros. From the original question's answer:

... Internet explorer automatically downloads the file into a directory I choose without asking?

You can use the free iMacros for Internet Explorer addon. It supports download automation via >the ONDOWNLOAD command (just record the download sequence, then replay it via iMacros. It is a >macro recorder for the web browser.

http://www.iopus.com/imacros/compare/all/

share|improve this answer
1  
Thank you for your introduction to iMacros. I know that Željko Filipin has also posted AutoIt scripts for automating the clicking of the File Download Dialogue. Just one thing: I am not interested in automating the popup, I do not want it to appear. –  Seubei Jun 23 '11 at 1:15
    
Aha. Alright - sorry 'bout that. –  kalaracey Jun 23 '11 at 1:44

I have solved this problem now. I hope the following information would help you:

Solution 1

Open Internet Explorer > Tools > Internet Options > Advanced > Security :
Clear the 'Do not save encrypted pages to disk'.

Clear the 'Do not save encrypted pages to disk'

Solution 2

Open Internet Explorer > Tools > Internet Options > Security > Custom level > Download :
Select Disable for 'Automatic prompting for file download'.
Repeat this for all 4 zones.

Disable automatic prompting for file download

Solution 3

Open My Computer > Tools > Folder Options > File Types > PDF > Advanced :
Clear the 'Confirm open after download'

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.