Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to run Meld (a diff tool written in python) but it quits with the following error :

Meld requires Python 2.5 or higher. 

Facing restrictive corporate guidelines i have to stick to the already installed Python 2.4.3 Is there a way to make Meld run despite that?

My system is RHEL 5.5

share|improve this question
    
I'm pretty sure it would be quite difficult to backport Meld to Python 2.4. Here are the Python 2.5 features, and some of them look like a real pain to get rid of. –  Daniel Beck Feb 16 '11 at 16:04
    
Arrr! Its too bad. I had a slim hope because on the meld homepage the requirements say "2.4 or higher". But on the other hand the site still advertises the 1.3 release with 1.5 out for two month already. –  kostja Feb 16 '11 at 16:34
    
The 1.3 works as expected though. Could be worse :). Thank you, Daniel Beck –  kostja Feb 16 '11 at 16:35
    
Even the 1.4 works. I was simply discouraged by the uncooperative ops. –  kostja Feb 16 '11 at 16:38
    
RHEL is a server platform. meld is a GUI diff/merge client. Do you run RHEL on your workstation? Also, as alternative you could try using diffuse (diffuse.sourceforge.net), it claims to work with python 2.4 –  vtest Feb 16 '11 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.