Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The problem started when I uninstalled my ATI graphics driver and i used a driver cleaner.

After i restarted win7 and it got to POST the screen just went completely blank. So i Used system restore from the repair menu to get back on.

I found out that if I ran chkdsk the display just goes black after restart on startup and i have to use system restore to get back on windows7 not sure why this is.

When i right click desktop and choose 'Screen Resolution' it says No such interface supported. Also when I click items such as device manager in the windows explorer it does not do anything.

I have tried re-registering the DLLS but that did not do anything.

share|improve this question
Have you scanned for malware? – Moab Feb 16 '11 at 16:31
its not malware. this happend right after i used "driver sweeper" i'm pretty sure it must have removed some important windows files – tom Feb 17 '11 at 0:03
I smell scam... – Hello71 Feb 17 '11 at 2:51
@Hello71 & @Moab Not a scam or malware, it's just badly written software. See my post. – Tog Feb 17 '11 at 11:06

Have a read here on the AMD forums, the relevant bit is this:
(The relevant text is in bold)

Apparently Driver Sweeper deletes (cleans up) entries and files for ATI video drivers that are actually part of the original Windows 7 install package. When you attempt to install Win 7 SP1, the installer finds that these entries and files are missing and fails with an error code 0x800f0a13.

The author of the software is looking into a fix. Reference is here

I will look into this for the next version of Driver Sweeper, I'll make sure that the restore of Driver Sweeper will be able to restore all the files and directories. Driver Sweeper always has backups of all files and directories, if it's not possible to create a backup the file/directory is not deleted.

So it looks like some files cannot be restored by the user or the program (at this time)

share|improve this answer

If the issue is related to windows registry entries and you have system restore points enabled you should be able to navigate to Start>All Programs>Accessories>System Tools>System Restore and select the point where you either installed or ran the driver cleaner. This will reset any changes to the registry.

If it also ripped out any important files it's a bit of a craps shoot. You can try downloading and re-installing the video driver which would resolve any missing driver files such as DLLs but if it took out any required files from windows then you may be looking at having to run a backup and then run a full system restore in order to remedy the issue.

share|improve this answer

Having a similar issue on Windows 2012, where it suddenly stopped opening Explorer.exe on Windows logon, and displayed a black desktop. Any attempt to load Explorer.exe failed with error "No such interface supported".

I found a solution in :

From Task Manager (CTRL + SHIFT + ESC), open CMD and run:

FOR /R C:\Windows\ %G IN (*.dll) DO "%systemroot%\system32\regsvr32.exe" /s "%G"

It will take some time and will open many Runtime errors messages, you can close them all. Once completed, restart windows ( shutdown -r -t 0 ), and hold fingers...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .