Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use a 32bit installation of eclipse on my 64bit windows machine.

I have eclipse extracted to my C: Drive and Java installed in ProgramFiles(x86)

When I go to start eclipse I get the error:Failed to load the JNI shared Library"C:Program Files(x86)\Java\jre6\bin\jvm.dll"

I looked and the file is not there.

I am setting something up wrong?Just did a fresh install of Java before trying to run eclipse.

share|improve this question
1  
Have you installed the 32-bit version on JDK ? –  Sathya Feb 17 '11 at 11:53

1 Answer 1

up vote 2 down vote accepted

You need to make sure to have both:

  • a 32bits Eclipse installation
  • a 32bits Java installed: so make sure the JDK installed is actually a 32bits one, as this comment details:

I have a 64 bit Windows 7, didn't check if I had the 32 or 64 bit Java installed.
Easy and fast check to do, is whether or not your Java folder is in Program Files or Program Files(x86).
If you've got both of these maps and it's in the x86 one, you'll need the 32 bit download.

See also the SU question "Eclipse - Failed to load the JNI shared library"

share|improve this answer
    
Thanks got it working –  james Feb 19 '11 at 0:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.