Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Sox, i installed lame-398, but sox is not able to convert any file to mp3. It fails with the messages:

./../sox FAIL util: Unable to load LAME encoder library (libmp3lame).
./../sox FAIL formats: can't open output file `funktech.mp3':  

How can i check if lame has been installed correct? How can i get sox to find the mp3Library?

edit: I did not install sox at all, it works without installing directly from the commandline. Lame was installed by following the instructions on their site:

./configure
make
make install

which results in the following files being found in /usr/local/lib/ : libmp3lame.dylib, libmp3lame.la, libmp3lame.a Maybe symlinking libmp3lame.la, which is marked as executable, to /usr/bin would help?

share|improve this question
1  
You should consider telling us how you installed these programs. – Daniel Beck Feb 17 '11 at 13:40
2  
I have the same issue. Although the sox OS X readme states to only place libmp3lame.dylib in /usr/lib or /usr/local/lib, the latter of which is used by Homebrew (and I filled the former with symlinks), it doesn't work with the download version of sox. – Daniel Beck Feb 17 '11 at 15:40

Brew didn't pull in lame when I installed sox. After a bunch of searching and trial and error, I figured out:

$ brew install lame
$ brew reinstall sox # or "brew install sox" if you don't already have it installed

Now sox can write mp3s.

share|improve this answer
3  
now there's a --with-lame flag for sox. – glasz Sep 20 '13 at 23:08
    
The --with-lame flag did the trick for me. Without it sox could play MP3 files but could not encode them. Thanks @glasz! – Adam Wildavsky Aug 22 '14 at 22:56

I installed sox using Homebrew. It automatically downloaded the lame dependency and works like a charm.

$ brew install sox

I tried it using:

$ sox somepodcast.mp3  -C 12 test.mp3

test.mp3 sounds worse than somepodcast.mp3. Mission accomplished.

share|improve this answer
1  
I don't like this as an answer to this specific issue, as it depends on a tool i don't use. And it just tells me that i could have done things another way, which doesn't help me to understand whats going on. But i like Homebrew, which i didn't know until now, thank you for that. – marue Feb 17 '11 at 15:25
2  
@marue It's the best I could do without you having explained how you installed it. Plus, it works. – Daniel Beck Feb 17 '11 at 15:29
    
Of course, i didn't want to offend you in any way. Thank you for your efforts. – marue Feb 17 '11 at 18:54

I had to do this:

brew reinstall sox --with-lame
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .