Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I face a very strange symptom on my Acer Aspire laptop (with the factory default Win7 install and divers. Windows update running).

After waking the computer from hibernation, it is a pain to type, since on average 5-10 keypresses are missing per 100 presses, using the laptop's keyboard. Steps to reproduce:

1) Power off
2) Power on, wait for system to become usable
3) Open notepad, for 5 times do hit 10x the same character. This gives a similar pattern of 50 chars total:

xxxxxxxxxxyyyyyyyyyyaaaaaaaaaassssssssssdddddddddd

4) Optionally repeat. Everything is fine this far.
5) Hibernate.
6) Power on and resume.
7) Repeat steps 3)-4). This time approximately 3-5 character will be missing from each 50 characters.

What I ruled out:

  • putting to Sleep or just Locking and resuming from there does not cause problem
  • battery / AC usage does not matter
  • net connection does not matter
  • running processes seem to be the same before and after hibernation
  • key press speed doesn't really matter. For the test I use a nominal 3-5 strokes/second beat.
  • plugging in an external USB keyboard works fine, but the built-in one still misbehaves

What could be the problem? How could I diagnose if the keypresses arrive in, but get swallowed at some point? (maybe some nasty keyboard handler hook misbehaves?).

Update: It seems that pushing the PowerSmart button and toggling to power saving state fixes the problem. Also, toggling it again back to the original state keeps it fixed. So this may be a fine workaround, but is not a conforming solution.

share|improve this question

1 Answer 1

Did you try to Allow hybrid sleep to see if the problem persists?

Windows 7 Hibernate Problem

There are at least two different types of hibernation problems. One problem is that your computer is not waking up properly. Alternatively your problem is there is no Hibernate option on the Windows 7 Shut Down menu. In both cases check the 'Allow hybrid sleep' setting.

1) For any hibernation problems the easiest solution is to set 'Allow hybrid sleep' to: 'Off'. (See screenshot).

Screenshot

By design, hybrid incorporates both Sleep and Hibernate, thus you only see Sleep on the Shutdown menu. Also, by default, desktops are set to 'Allow hybrid sleep :On'.

Trap: Before you can change any of the Balanced settings, first you must click on Change settings that are currently unavailable. (See screenshot)

Read more about hibernating problems here.

share|improve this answer
1  
@ron: I didn't receive any feedback whether your problem is solved. Dis you tried my suggestion? Did you used another fix? –  Johnny Apr 20 '11 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.