Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have a folder name ending in .theme and I can't change it to anything else. (It's part of a Plone installation with XDV.) This makes OS X think it's an iDVD theme, not a folder. To browse its contents, I have to right-click "Show Package Contents". How do I make Finder treat it like a normal folder? (I don't use iDVD.)

share|improve this question
    
Remove the extension? –  Wuffers Feb 17 '11 at 17:08
    
No, as I said in my question, I can't change or remove it. –  francois Feb 17 '11 at 17:39

1 Answer 1

up vote 1 down vote accepted

iDVD's Info.plist defines the file type and that it's a package. Therefore, you need to get rid of it, or edit the Info.plist. Since the latter is likely a major pain, and you don't use it anyway, remove it.


Uninstall iDVD (if possible), or delete the iDVD application bundle.


Then either rebuild the launch services database by entering the following in Terminal:

/System/Library/Frameworks/CoreServices.framework/Frameworks/\
LaunchServices.framework/Versions/A/Support/lsregister
-kill -r -domain local -domain system -domain user

or restart your machine.

share|improve this answer
    
Wouldn´t it be "easier" to modify the <key>LSTypeIsPackage</key><true/> to <false/> underneath the <key>CFBundleTypeExtensions</key><array><string>theme</string></array>in iDVDs info.plist? –  Asmus Feb 18 '11 at 12:45
    
@Asmus I don't have iDVD installed and didn't know the plist format -- and I cannot assume that someone has the Developer Tools installed. Plus, you'd have to remember to repeat this every time there's an iDVD update (granted, there don't seem to be many of those AFAIK). Since he doesn't use it, he can simply trash it. –  Daniel Beck Feb 18 '11 at 12:52
    
Ah, you´re right on updates, forgot about that. Well the other option to do this (by associating .theme files with another .app that has LSTypeIsPackage:false) is way over the top, so I guess your answer is the "easiest" way to go :-) –  Asmus Feb 18 '11 at 13:01
    
Thanks Daniel! I deleted the iDVD application bundle and restarted, which fixed my problem. It seems the Terminal command wasn't needed (I also didn't seem to have LaunchServices.framework/ or lsregister on my computer.) –  francois Feb 18 '11 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.