Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Ubuntu 9.10 I configured manually network settings to /etc/network/interfaces, and it works fine when I run /etc/init.d/networking restart.

Problem is that those settings are not loaded to GUI application (Preferences/Network connections).

I don't want to edit my preferences there, I just want to use my interfaces file as default! Do you know what's going on?

share|improve this question
up vote 1 down vote accepted

remove the auto DEVICENAME and simply write it like this (DHCP):

iface DEVICENAME inet dhcp

or for a static ip:

iface DEVICENAME inet static
address XXX.XXX.XXX.XXX
netmask XXX.XXX.XXX.XXX
gateway XXX.XXX.XXX.XXX

If you have written for example auto eth0 this means, that this interface is configured by the gui.

share|improve this answer
    
Ok I'll try that, I removed the auto eth0 line. – luca Feb 17 '11 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .