Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Mac PC and a Windows PC on the same network.

If I turn the firewall off on the Windows PC the Mac can ping it, if I turn it on, the Mac cannot.

I've checked every individual option in the firewall, but it still is not working. What rule do I need to apply to allow the Mac to connect? Or what am I doing wrong?

Using Windows 7 and OS X Snow Leopard.

share|improve this question
    
Your firewall might be blocking ICMP packets not allowing it to be pinged. You might still be able to access it though if it is connected to the internet. –  paradd0x Feb 17 '11 at 21:23
    
I tried to allow all ICMPv4 packets through, but still no luck. Crazy thing is, it used to work yesterday, and I never changed any firewall settings, anywhere. –  zm15 Feb 17 '11 at 21:29
    
What kind of firewall are you using? The Windows Firewall? Or a Third Party firewall? –  paradd0x Feb 17 '11 at 21:32
    
Windows Firewall. UPDATE: so I allowed all connections for ICMPv4, domain, public and private. That worked, but it seemed a little unsafe. Is it ok to leave this open? Allow all connection from this? –  zm15 Feb 17 '11 at 21:36
2  
Unless you are worried about bad ping packets from some unknown source. No. It's nothing to worry about. And it's not really a connection, since most connections are done in TCP and UDP. ICMP is mostly for ping packets. So you should be fine by leaving it open. –  paradd0x Feb 17 '11 at 21:38
show 1 more comment

2 Answers 2

up vote 1 down vote accepted

Your firewall is blocking ICMPv4 packets not allowing it to be pinged. Opening an exception for them in the firewall should help. There is also a very low risk of getting problems from setting that exception in ICMPv4 as most internet connections are done with TCP and UDP

share|improve this answer
add comment

Here's some info on creating the ICMPv4 rule in Windows 7's firewall from scratch.

If you have IPv6 enabled and working you may have to also add a similar rule for ICMPv6.

These rule(s) should also already be in the "File and Printer Sharing" group of 'predefined' rule sets in the firewall (it'll offer Predefined sets as a choice when you click "New Rule").

You also only have to apply this rule to the networking 'domain' it thinks you're in for your network (ie: Home, Work or Public).

If it WAS working, and then it wasn't, perhaps re-detected the network and it's now set as 'Public' instead of a trusted "Home" or "Work" network. You may want to double-check that as well.

Hope that helps...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.