Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 10.10 on Virtual PC 2007 on my desktop Windows machine. The internet connection has failed. Any tutorial on getting this working?

share|improve this question

In the Virtual PC settings for the Ubuntu VM, ensure the network adapter is set to 'bridged' or 'NAT' mode. If I remember correctly, bridged mode on VPC will just display the name of your hardware network card on the host instead of saying bridged. NAT will provide you internet connectivity through your host machine, while bridged will allow you to give your virtual machine it's own IP address on your LAN.

After setting it to one of these two modes, use NetworkManager in the top-right corner to confirm DHCP is operational and you have connectivity.

share|improve this answer
"use NetworkManager in the top-right corner to confirm DHCP is operational and you have connectivity." I didn't find that in Ubuntu. Where exactly is it located? – Yang Feb 18 '11 at 1:43
I don't see that option in my network. All I have is: Wired Network Auto etho Disconnect VPN Connections – Yang Feb 18 '11 at 1:49
I didn't mean the options, I meant the NetworkManager icon itself. If it says "Auto eth0" then it is configured for DHCP. – John T Feb 18 '11 at 1:50
Right I clicked on the icon itself. And those are all choices I have. I connected to Auto etho but still cannot get online. – Yang Feb 18 '11 at 1:57

Problem solved. Have to overide the http_proxy setting due to company network settings.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.