Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been banging my head against the wall for a long time now trying to get remote desktop working on my Win 7 machine.

Here are the things I have tried:

  • I have verified using http://www.canyouseeme.org/ and other services that the port is accessible.
  • I can use remote desktop inside my local network.
  • Port forwarding seems to be configured correctly.
  • I have disabled the firewall on both my local computer as well as my DSL Router.

One thing that does concern me is that when I look at the listening ports section on the network tab of the Resource Monitor, the firewall status is Not Allowed, not restricted. I'm not sure what Not Allowed means but it seems suspicious.

I am at a loss for other ideas to check. It seems that I must be missing something obvious but I can't think what it would be.

share|improve this question
add comment

2 Answers

I would first ensure:

  • The Windows 7 machine's power options are not turning the computer off after a few minutes
  • The port is forwarded for TCP traffic, not just UDP
  • It's a long shot, but check with your ISP to see if they block this port at their level as a security measure. Typically outgoing SMTP and (sometimes) incoming Web is blocked, RDP wouldn't surprise me nowadays.

Also try explicitly adding mstsc.exe into the allowed list of applications.

share|improve this answer
add comment
up vote 0 down vote accepted

It turns out that my router wasn't forwarding the port properly when I was trying to access my outside IP address from the inside. The router seems to be taking all the traffic itself when it sees that the traffic is coming from inside instead of forwarding it to the proper machine.

This isn't ideal but I guess it is what I have to work with...

share|improve this answer
1  
That's a very common behavior; forwarding traffic destined for the external IP back to the internal network is called hairpinning, and not all NAT devices implement it. –  Eric Feb 27 '11 at 3:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.