Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My internal Windows 2008 AD network is 172.20.xxx.xxx

My Apple Wireless base station only allows DHCP 172.16.xxx.xxx

Private IP address ranges:
10.0.0.0 to 10.255.255.255
172.16.0.0 to 172.31.255.255
192.168.0.0 to 192.168.255.255

The problem:
The internet works from my iPad that has a 172.16.xxx.xxx address, but I can't access (browse) my tools server that is 172.20.xxx.xxx that host my Filemaker database. Is it possible to add 172.16.xxx.xxx range somewhere in DHCP or DNS on my Windows domain server so I can access tools? Or is there another way to make this connection work?

share|improve this question

migrated from serverfault.com Feb 18 '11 at 14:26

This question came from our site for professional system and network administrators.

1  
What makes you think you can only have a 172.16.x.x DHCP range on an Apple base station? that's just not the case, besides this is a question for our sister site superuser.com –  Chopper3 Feb 18 '11 at 14:26
    
Can you clarify the physical layout of the network? It sounds like the 172.20 network is off a router attached to the apple base station, performing a second layer of NAT, in which case the network architecture would need to change for this to be possible. –  Jeremy Sturdivant Feb 18 '11 at 14:30
    
:From guernsey1962: Thanks for you help. I need guest access enabled on the Apple Airport Extreme II basestation, so I need connection sharing setting: "Share a public IP address" Guest access does not work in: Off(Bridge Mode) I am getting Double Nat warning message on the Aiport Basestation. When a do set it to Bridge Mode I can see my FileMaker Database, but then I can't have guest access. It would be nice if Apple had more options on it's basestations. –  KronoS Feb 25 '11 at 2:00
    
@guernsey1962 @user30472 I just saw your comment. If you need the AirPort Base Station to do NAT so it can do Guest Network, why not put it at the head of your network and have it be the NAT for the whole network? –  Spiff Apr 10 '11 at 7:34

2 Answers 2

If you can't use Bonjour to discover (browse/access) your Filemaker server, it's probably because your base station is running NAT, which blocks multicasts between [W]LAN and the WAN port. Having NAT enabled is also why the AirPort Utility is restricting what DHCP ranges you can use.

If you've already got a DHCP server on your network serving 172.20.x.x addresses, then put the base station in bridge mode and let your iPad get a DHCP lease from your existing DHCP server (this is probably the best case). You probably already have a NAT on your network as well, so turning off NAT on the AirPort base station is good since it avoids double-NAT, which can be problematic.

If you don't already have a DHCP server on your network and you want the base station to just be your network's DHCP server and not its NAT gateway, then switch it to "Share a range of IP addresses" (this is Apple-speak for "NAT service off, DHCP service on"). Once you do that, it should let you put in any reasonable address range for the DHCP server. It might warn you that using RFC 1918 private addresses might not be what you really want to do in that mode, but I think it lets you ignore the warning and it works.

share|improve this answer
    
Manually set your subnet mask on both your IPad and the tools server to 255.240.0.0 and both devices should be able to see each other. A better solution is to change the IP of your tools server to a 172.16.xxx.xxx address. An even better solution is to tell your Apple base station to hand out 255.240.0.0 as a subnet mask in the DHCP options; I'm sure it's possible somehow. –  ultrasawblade Feb 18 '11 at 14:44
    
If he can't browse to his server, he's likely using a multicast-based service browsing protocol such as Bonjour. Bonjour works as long as you're in the same multicast domain, so if that's failing, he's probably got NAT in the way, and adjusting subnet masks isn't going to help. Also, Apple base stations don't let you set your own subnet masks for the DHCP service. –  Spiff Feb 19 '11 at 5:19

Thanks for you help. I need guest access enabled on the Apple Airport Extreme II basestation, so I need connection sharing setting: "Share a public IP address" Guest access does not work in: Off(Bridge Mode) I am getting Double Nat warning message on the Aiport Basestation. When a do set it to Bridge Mode I can see my FileMaker Database, but then I can't have guest access. It would be nice if Apple had more options on it's basestations.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.