Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get this error if I've been closing and restarting my SSH sessions in a short window of time and goes away after awhile. I'm sure my password is correct. Each of my two client's response to the error doesn't give me a lot to go on for search engine troubleshooting.

Under mRemote on Windows 7, outside the main window a 2nd window is drawn which disappears immediately. The shell I opened (in a tab) will display only Using username "Bob". for a second or two before closing without notice.

Connectbot on Android is more specific. It connects to host and verifies. After the password prompt it tells me Authentication method 'password' failed.

What is happening here?

share|improve this question
1  
What does the server's logs say? Run sshd -rdd for diagnostic messages. –  grawity Feb 18 '11 at 22:52
1  
@grawity gist.github.com/839208 Was transcriped and checked for errors but might have small errors or transpositions due LD –  aesthetic priest Feb 22 '11 at 19:31

1 Answer 1

I had the same symptom. In my case, the problem was as silly as having entered an extra space at the end of the user name on connectbot's configuration

My server's log (Ubuntu server) would display the error:

> tail -f /var/log/auth.log
...
Jan  5 00:27:03 wimel sshd[21366]: Invalid user coderazzi  from 62.143.154.115

This line was displayed as soon as I would try to connect: password was never used, in fact.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.