Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I dock my Windows 7 laptop, I want it to prefer the wired ethernet connection over WiFi.

This is a pretty straightforward thing to do on my Mac - I just reorder my network preferences, and it "does the right thing." I just can't figure out how to achieve the same thing on my Win7 laptop.

So, when I'm docked, it connects to WiFi, and then fails to connect to servers on the local wired network. How do I fix this?

share|improve this question
    
With windows I've always used IBM Access connections, which would now be Lenovo Access Connections. But this could only be installed on Lenovo Hardware. Thus try the answer to this question: superuser.com/questions/214427/… Maybe you could even use the Access Connections Software? www-01.ibm.com/common/ssi/cgi-bin/… –  Darokthar Feb 18 '11 at 19:53
    
This is answered here: [enter link description here][1] [1]: superuser.com/questions/237892/… –  Ryan E Aug 22 '12 at 22:55

9 Answers 9

It's on Windows 7, but it's pretty well hidden.

Go to Control Panel -> Network and Sharing Center -> Change adapter settings -> The hit Alt to get the menu and choose Advanced -> Advanced Settings.

Then you can re-order your connections in that list.

Although Windows should already automatically prefer your wired over your wireless connection. It chooses what adapter to use based on the lowest interface metric, and a wirelesss connection should have a higher metric than your wired. Run route print from the command prompt to see that.

share|improve this answer
7  
This solution didn't work for me. I've ordered my connections: (1) Local Area Connection, (2) Wireless Network Connection. When I connect to the public WiFi network, I can't access internal sites. When I disconnect, I can. It still seems to be preferring WiFi. –  jkooker Feb 18 '11 at 23:59
    
Does your wired and wireless connections both have a default gateway set (check via ipconfig)? Multiple, different, default gateways will cause routing issues. If that's the case then you could probably fix you issue by adding a static router via the route command. We'd have to know your IP address setup and the addresses of the server's that you are trying to connect to to help you with that. –  shf301 Feb 19 '11 at 4:30
    
it's perfectly legal to have multiple default gateways; it's the norm. only one will be used, but the others are still there in case one of the interfaces disappears (unplugged cable, wireless turned off) –  Michael Lowman Feb 19 '11 at 5:22
    
True, the problem is when the different default gateways don't have the access to the same networks, which is jkooker's case. See his comment to your answer. In his case changing default gateways changes which network is accessible. That was the context I was thinking in. –  shf301 Feb 19 '11 at 14:41
1  
Use the instructions at the end of this KB article: support.microsoft.com/kb/299540/en-us –  shf301 Feb 24 '11 at 18:54
  1. Click Start and, in the search field, type View network connections.
  2. Press the ALT key, click Advanced Options and then click Advanced Settings.
  3. Select the Wireless Connection and move up for top priority.
share|improve this answer

Two things: first, you can add a metric to each interface to specify that one is better than another. Using the GUI, go to your network connection's properties, TCP/IP, Advanced, uncheck Automatic metric, and fill in the appropriate number. Since the metric represents a cost, Windows will automatically use the interface with a lower metric if it can't decide. This KnowledgeBase article describes the feature you're disabling.

Second, you shouldn't ever have a problem that requires one interface to be used over another. If both interfaces are the same network, then you'll always want the fast one. If they're different networks, then routing tables will automatically send packets out the proper interface to reach the network they belong to.

Perhaps you have two physically separate networks with the same IP block? This is a misconfiguration, and you should fix it.

share|improve this answer
    
This is at work, so the wired network has access to internal sites, and the wireless network doesn't. –  jkooker Feb 18 '11 at 23:15
1  
ok, i'll still argue this is a configuration issue, but not one you can solve at the source. so just give your wireless interface a higher metric, and the wired network's default gateway will be used. again, route print helps. I have two interfaces, one with a metric of 20, the other 10. The default gateway (dest 0.0.0.0, mask 0.0.0.0) used will be the one with the lowest metric. –  Michael Lowman Feb 19 '11 at 5:19
    
This solution worked for me, it seems. –  Peter Jaric Dec 17 '12 at 9:07
    
This worked for me, but I had to mess around with it a bit. I changed my Wired connection metric to 10 and Wireless connection metric to 20. When I used route print, it showed the Wired as 250-300 and the Wireless to 20-30 each time. To get around this, I just set each to the extreme. Wired = 1, Wireless = 999. I now get the proper order. Thanks! –  Lyrical Feb 19 at 9:39

Go to Control Panel -> Network and Sharing Center -> Change adapter settings -> Then 'Right Click' on the Wireless network and select Status Then click Wireless Properties and make sure that if you have it set to connect when in range that it is also set to connect to Connect to a more preferred network if available.

share|improve this answer

If you have a wireless switch on your laptop, you may want to turn that off. Another thing you can look at is whether your ethernet port is operational in the device manager. You can also set this up through your internet options as well.

share|improve this answer
1  
turning off wifi works, but is a hacky solution. –  jkooker Feb 18 '11 at 23:58

I got it working by setting the metric setting to 10 for wired and 1000 for wifi, all the other suggestions I found didn't work.

share|improve this answer

My problem was that DHCP was not enabled for my LAN Connection - ran the troubleshooter, it turned it on and all is well now.

share|improve this answer

i had a similar problem at home when i ran an ethernet wire to my computer after using wireless for a long time. my wifi was set to connect automatically, even though i had an ethernet connection.

my solution:

  • control panel
  • network sharing
  • change adapter settings
  • right click on wireless network, while connected
  • click status
  • wireless properties
  • uncheck "connect automatically when this network is in range"

not exactly the same but someone might find this usefull.

share|improve this answer
  1. Go to Control Panel > Network & Internet > Network Connections
  2. Right click on your Wifi Network Adaptor usually titled "Wireless Network Connection"
  3. Select Properties
  4. Click on the "Configure" button
  5. Select Advanced tab
  6. Under "Property" Scroll down to "Disable Upon Wired Connect" and highlight it
  7. On the Right-hand side under "Value", select "Enabled" in the drop down menu
  8. Hit OK
  9. Disable then Enable back Wireless Network Connection.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.