Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Linux Mint on my Dell Latitude D600 and I am having problems with the USB port. When I insert a USB flash drive or an external USB hard drive into the USB ports the USB device light turns on but Mint does not detect the USB device.

The USB drive used to work but all the sudden it stopped working. Any idea how to fix this?

share|improve this question

migrated from stackoverflow.com Feb 18 '11 at 23:38

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers 2

This could be an /etc/fstab issue.

Run dmesg after plugging the device. You will get something like the following:

sd 7:0:0:0: [sdc] 8028160 512-byte logical blocks: (4.11 GB/3.82 GiB)
sd 7:0:0:0: [sdc] Write Protect is off
sd 7:0:0:0: [sdc] Mode Sense: 03 00 00 00
sd 7:0:0:0: [sdc] Assuming drive cache: write through
sd 7:0:0:0: [sdc] Assuming drive cache: write through
 sdc:
sd 7:0:0:0: [sdc] Assuming drive cache: write through
sd 7:0:0:0: [sdc] Attached SCSI removable disk

The value in the brackets is the device. For the answer's purposes, I will use sdc. Yours may be different.

Go to the /mnt directory and run mkdir usb

Then, run su -c "nano /etc/fstab" and add a line like this:

/dev/sdc    /mnt/usb  auto user 0 0

Save.

Reboot and you should be able to find the device in your file manager and mount it as any user, with read-write access under the directory /mnt/usb.


This is my solution for a distro without an automounter (Zenwalk). You may have a problem with your automounter, and that is a different can of worms.

Also, kernel version (ie uname -r) and file manager may affect this.

share|improve this answer
    
Hi, thanks for your answer. It seems that my problem was related to the automounter. –  doorman Feb 20 '11 at 14:47
add comment
up vote 1 down vote accepted

The problem was related to the automounter in my case. I was using ndiswrapper for wifi communication through usb the other day and it seems it disabled the usb automount.

To fix it you need to do this:

sudo gedit /etc/modules

And you need to add the following lines:

usb_storage
usbhid

Source: Web Upd8: Ubuntu / Linux blog - Fix USB devices' automount not working.

share|improve this answer
    
Welcome to Super User! If you want to thank an user, please gain some reputation and comment on his answer. Else that user won't be informed... :-) –  Tom Wijsman Feb 19 '11 at 15:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.