Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have Ubuntu installed on a USB stick, but when I try to boot from it, none of the boot options that start with USB work. There is a USB-HDD and USB-Zip, but both of them just skip and boot to my harddrive. I have a Gigabyte P35-DS3L motherboard, and before it boots the usb stick shows in the POST screen. How can I boot from the stick?

share|improve this question
    
What BIOS do you have? –  bobobobo Feb 19 '11 at 1:38
    
Award Software International, Inc. F5, 9/7/2007 –  Kironide Feb 19 '11 at 1:44
    
How did you set up your USB stick? (When I first did this I needed to reformat the USB stick just right). –  Richard Feb 19 '11 at 9:18
    
I made it purely in Unetbootin –  Kironide Feb 19 '11 at 15:03

4 Answers 4

up vote 0 down vote accepted

Do you know that the USB stick setup is bootable - can you try it on another PC?? You don't say how you made the Ubuntu stick, but there's a great app that will do it pretty much automatically for you so if you don't mind starting again (wiping the stick or using a second one), try Unetbootin - of course, if that's what you used to make the stick in the first place then the mystery continues and is probably down to your system board/BIOS.

share|improve this answer

Try the Plop Boot Manager (freeware), put it on a floppy. It sort of bypasses the BIOS.

You need it on a floppy or CD. It's lovely and works.

I still have a later problem with the install though on an old machine. Hangs when loading Ubuntu from the stick.

The Plop Boot Manager is a small program to boot different operating systems. The boot manager has a built-in ide cdrom and usb driver to access that hardware without the help/need of a bios. You can boot the operating systems from hard disk, floppy, CD/DVD or from USB. You can start the boot manager from floppy, CD, network and there are many more ways to start the boot manager. You can install the boot manager on your hard disk. There is no extra partition required for the boot manager.

share|improve this answer

I am assuming you're using OS X or Linux, since you didn't say.

If you create the USB-stick with "dd", make sure you copy it to the right place. Usually, /dev/sdf1 should work (assuming it's sdf, check with dmesg or fdisk -l), but in some cases only /dev/sdf will work.

Creating the USB-stick with "unetbootin" is also a good option.

Also, make sure your BIOS-settings are set correctly, to boot from the USB-stick.

Not that some old USB-sticks does not support being booted from.

share|improve this answer
    
"I am assuming you're using OS X or Linux, since you didn't say." - You might want to read the 4th word of the OP again. –  MDMarra Feb 19 '11 at 1:34
    
MarkM, it is not said what OS is currently in use, only that the OP is trying to boot Ubuntu from an USB stick. You're the one that might want to read the question again. –  Alexander Feb 19 '11 at 1:40
    
The OS on the hard drive is irrelevant. If the bootloader is on the USB drive like it should be, the HDD doesn't matter at all. –  MDMarra Feb 19 '11 at 4:58

On an ASUS board with the American Megatrends BIOS, I had this same problem.

Under Boot you see:

  • Boot device priority
  • Hard Disk Drives

Go into HARD DISK DRIVES first. You should see all your HDD's and the USB stick enumerated. For me, the USB stick was the last drive in the list. The first drive was the primary HDD.

(If you have more than one HDD be sure to write down the serial number of that bootable HDD)

Now make the USB stick appear #1 in the list by pressing enter on the first slot and selecting your USB Stick. That will probably make your primary HDD move to the bottom slot..

Once you've done that, back out of that menu and go to BOOT DEVICE PRIORITY - you will find your USB stick now an option when you press enter.

Unfortunate side effect may be your primary HDD is no longer listed, fiddle with the order until it works.

I don't know why they designed it this way, seems pretty odd to me.

share|improve this answer
    
I tryed changing this but the only ones were my HDD and a "Bootable Addons", which when I tried selecting it booted to my HDD anyways. –  Kironide Feb 19 '11 at 6:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.