Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently upgrade to Ubuntu 10.10 Maverick Meerkat and to my dismay, the mediakeys "volume up" and "volume down" do not send Dbus signals anymore... how can I add these back?

Thanks!!

share|improve this question
up vote 1 down vote accepted

It would appear that the root cause of this problem is the service HAL: somehow, this service isn't started most of the time on my machine. To start, use:

sudo hald --daemon=yes

share|improve this answer

To configure the keys used for volume up, and volume down, press ALT+F2, type in gconf-editor, and press Enter. Then, navigate to /apps/gnome_settings_daemon/keybindings.

The values on my system are:
volume_down -> XF86LowerVolume
volume_up -> XF86RaiseVolume
volume_mute -> XF86Mute

If those don't work for you you can use xev to figure out the exact keycode your media keys fire and configure those.

share|improve this answer
    
the problem isn't the keycodes nor the functionality associated with the keys per-se but the lack dbus signals generated as a result of pressing those media keys. – jldupont Feb 21 '11 at 12:24
    
If gnome-settings-daemon is picking up on the keypresses but not firing the dbus signals then there is a bug in that package. You can report it to Ubuntu with specific information about your system by running apport-bug gnome-settings-daemon. – Patches Feb 21 '11 at 23:15
    
thanks for the pointer. I have filed a bug report: bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… – jldupont Mar 23 '11 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .