Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm have a D-Link DIR-615 Wireless N 300 Router. I didn't use the CD it comes with to set up the network. Instead I configured it manually through the router's settings that are accessed via a web browser.

The main changes I made are:

  • Secured the router so that a password is required before clients can use the wireless internet.
  • Broadcasting 802.11N only (not B or G).

I can connect to the router just fine and I'm able to access the internet. The only problem is that I don't see any of the other computers in my LAN. When I try connecting to another Wi-Fi router that I have (which is connected to the same network), I can see all of the computer's on my LAN just fine. Therefore, I'm guessing that the reason I can't connect to the LAN is not a problem with my computer and is a problem with the router instead.

I'm on a MacBook Air running Mac OS X 10.6.6.

I tried contacting D-Link technical support, but they only try to help you if you have problems connecting to the internet. They aren't really concerned with problems that have to do with the accessing PC's on the same network.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Turn off NAT and DHCP on your new router. You want it to be just a bridge between wireless and wired, not a whole gateway.

If your router doesn't provide a way to turn NAT off, you should basically turn the DHCP server off and then stop using its WAN port; plug it into the upstream network via its LAN port.

For further details of exactly how to do this on your D-Link DIR-615, See page 73 "Connect to Another Router" in the manual.

share|improve this answer
    
I disabled the "DHCP Server" option. However, this doesn't resolve the problem. I tried looking for NAT settings, but couldn't find any. The User's manual only mentions "NAT" once, and it's in an area that talks about application rules. –  Senseful Feb 20 '11 at 4:22
    
For wireless routers that don't have an option to turn NAT off, you basically have to turn the DHCP server off and then stop using the WAN port. Use a LAN port to connect to the rest of your network. See page 73 "Connect to Another Router" in the manual you linked to. –  Spiff Feb 20 '11 at 6:03
    
that worked perfectly. Could you please add it as an answer so that I can accept it? –  Senseful Feb 20 '11 at 10:12
    
@Senseful. Okay, I updated my Answer to add that clarification. –  Spiff Feb 22 '11 at 5:57

I have the same router you have, and basically the same setup (it was installed in a network that already had another router)

For your MAcBook see the other computers, they must all be on the same network (ie, share the same IP range, usually 198.168.0.xxx)

For that to happen, there are 2 key rules that must be followed:

  • Software: Since they are now in the same network, only 1 router will be used as internet gateway and DHCP provider. So you must disable those options in the new router, like this:

Go to your new routers page, then Setup -> Manual Internet Connection Setup -> Access Point Mode -> chek the "Enable Access Point Mode"

  • Hardware: both your routers, old and new, must be connected to each other using a wired connection. And for that you must use the LAN ports in both routers. LAN, not WAN. This way, they will share the same IP range, and the computers "behind" the new router (your MacBook) will be in the same IP range as the other compuiters behind the old router

That must solve your problem. Feel free to ask more info if you need

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.