Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7 if I have files arranged by date on the desktop with newest being last, then files are automatically places at the end (i.e. right bottom) as I update them.

The exception seems to be textfiles. Textfiles while updates never change their position on the desktop.

Why is this?

share|improve this question
    
No one knows what makes Windows 7 tick when it comes to file arrange, either on the desktop or in explorer, and there seems no way to change the behavior. –  Moab Feb 20 '11 at 13:15
    
Make sure the date you're seeing and sorting by is the date modified, not the date created or last accessed. –  martineau Feb 20 '11 at 16:49
    
I don't have that option when arranging desktop icons. –  Jay White Feb 20 '11 at 22:10

1 Answer 1

Right click on empty space in any folder, you see the "sort by", instead of clicking in "Date", click on "More..." . Then, is ordered by alphabet order all the options available. scroll to modification date or date modified. (can't remember) . Check that. Then rmb again and select "date modified" for sorting icons. Then go to top menu, Tools, Options, View, hit "Apply to all folders" button. I usually make this in top My Computer or Unit C folder, so I think it applies to all hardrive. The new option should always appear now in right click menu...

Edit: When ordered by date modified, might be happening to you, if disk is very full and fragmented and there are way too many files in that folder, it takes a second to actually auto update the folder and put the newest file at the very beguining. In my win 7 machine is like one second in the very worst case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.