Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows XP with the latest service pack on my old laptop.

I have a situation where I can Ping and status says connected but cannot browse. I have seen various post on the net proposing solutions that works for some and not for others I have tried reseting winsock but nothing. If I vpn to my work then I can browse.

I would like to avoid reformatting the computer and not take such a drastic action.

Any suggestions?

share|improve this question

migrated from stackoverflow.com Feb 20 '11 at 8:31

This question came from our site for professional and enthusiast programmers.

2  
Check your Firewall. –  aqua Feb 20 '11 at 7:28
1  
What are you trying to ping and browse? –  surfasb Feb 20 '11 at 8:36
    
Describe "cannot browse" - what happens or doesn't happen? Any error messages in the browser window or in the status bar? If it stalls on "Looking up example.com", your DNS is failing, either due to a bad network setting on your end, or your DNS provider is down. See if changing to another DNS helps - Google's DNS, 8.8.8.8, or OpenDNS, 208.67.222.222. (They may not be optimum for you if you aren't in the US, but might help you debug this). –  JRobert Feb 20 '11 at 13:30
    
Hi thanks all for your reply.I am in the UK.I get the usual error when you cannot connect to any site.Tried the above but not lack.It seems to work with IP Addresses but not names –  user9969 Feb 21 '11 at 7:45
    
"work with IP Addresses but not names" pretty much points to domain name resolution issues. Probably your DNS provider is down or very slow. Does the browser's status dwell on "Looking up example.com" or something similar, while you're waiting? That's another clue that it's DNS. And I assume ping exhibits the same behavior - works with IP but not with names? If so, next stop is your ISP's service desk, if you're using their DNS, or changing your DNS, or both. –  JRobert Feb 21 '11 at 22:57

2 Answers 2

up vote 2 down vote accepted

Maybe your DNS resolution is not working.

Try browsing using IP addresses, not names, to see if it works.

Enter 64.233.163.104 in your browser, and see if you can browse. (thats Google's website IP)

If it works, we can work from there

EDIT:

Given your comments, I have a strong suspition this is your ISP's fault: when you use IP addresses, it all works fast. When using names (meaning a DNS query is triggered), it works but it is very slow. This indicates your config is fine, but there is a problem @ your ISP.

My suggestion is: try to contact them, and ask if they are aware of any DNS problemns. Maybe they are doing some maintance in their servers. Also, ask about the IP numbers of their DNS servers. Then, use Start Menu -> run -> cmd -> ipconfig and compare if the currently assigned IP for DNS servers matches the ones your ISP provided you.

EDIT:

IP (numeric) addresses wil always be faster than using (textual) names like www.google.com. Thats because when using names it must translate the name into an IP address. Your machine query another computer (a DNS server) that has a table matching every name to its IP address. So how fast it is done depends on how fast/busy the DNS server is (and how good/crowed is the network traffic between you and the server)

So using public DNS servers, like you probably did when you searched solutions in the net, is not a good idea: they are usually very busy servers, and they might be "distant" (network-wise) to you. Distant server means high latency, slower response, leading to slow access.

The best solution is to make sure you're using the DNS servers your ISP provide you. Since its your ISP server, you have the fastest possible connection to it, and they are usually not so crowded like public DNS servers.

(small note: your machine (the OS / browser, actually) keeps a small record (a cache) of "recently queried" DNS names, so it only needs to translate www.google.com once. Subsequent browsing/pinging to same address will be (almost) as fast as using the IP address, because theres no need to query the DNS server again. The OS / browser just look at the internal DNS cache)

Hope that helps, and feel free to add more input if you need further help!

share|improve this answer
    
If that is the problem, why ping then works? –  Olli Feb 20 '11 at 12:54
    
If it is DNS, ping will work when you type in google's IP, but not when you type in google's domain name as the DNS lookup will fail. –  MaQleod Feb 20 '11 at 19:42
    
I have now tried different solutions found on the net and it works with names too but very very slow,not sure what I did as I tried different things.what I have noticed and not sure if it helps,that when entering the ping address is very very quick and with names very very slow.Any ideas? –  user9969 Feb 23 '11 at 6:27

My proxy issue came from using a guest image made for another network with Firefox Proxy Preferences set to "Use system proxy settings". Once changed to "Auto-detect proxy settings for this network" Firefox worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.