Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having trouble in setting up Virtualbox to allow Fedora 11 (guest) leave the virtualbox machine and pass through Mac OS X 10.5 (host). I found only this tutorial

http://vre.upei.ca/dev/node/497

but it does not match with my findings, and assumes that you have Parallels installed as well. Does any of you already have experience with this setup ?

I am able to enable NAT and get my vbox to download stuff from the net, but I also need to ssh into the vbox from my host machine. It appears that this is not feasible with the NAT option.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

As the above poster mentioned, you'd want bridged mode. If your network assigns via DHCP, you should get DNS that way.

You'll likely want to establish a static IP for your guest OS, however, to facilitate SSH access. If it is DHCP, your IP address is likely to change thereby creating some difficulty finding its address if you're not able to physically touch the VM.

Side note: I had a problem with my Lenovo T60 in bridged requiring a manual tap adapter script but this was hardware specific and I belive it's been corrected in subsequent releases.

share|improve this answer
add comment

You are referring to a Shared Networking setup and this works "out-of-the-box". I don't have Virtual Box in front of me but you need to configure the network card to use the Mac Network card when you setup the Virtual Machine. The trick with VirtualBox is the requirement of specifying the card during setup. Will update with detailed steps when in front of VirtualBox again.

share|improve this answer
    
let's see, trying right now –  Stefano Borini Aug 18 '09 at 18:34
    
Ok. so it appears that the situation was as follow: you need to configure it as NAT, but to be careful to setup the network interface of the host to be the one I'm using... (it defaulted to wifi, but I'm using ethernet). Unfortunately the names were not descriptive in the virtualbox settings so I could not get it was wrong until I tried. As you said, works out of the box. –  Stefano Borini Aug 18 '09 at 18:41
    
Unfortunately, I realized that this setup does not allow me to ssh into the virtual machine. –  Stefano Borini Aug 18 '09 at 18:46
    
You should be able to using the the local IP specified by Virtual Box. I know the VM can see the host and the host should be able to ping the guest. Again hard to confirm without being in front of it :) –  Diago Aug 18 '09 at 18:57
add comment

I think you should be setting the virtual box network adapter as bridged. You may need to manually set the DNS server in the fedora guest.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.