Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to compile and install the qca-ossl plugin for qca and qt. QT, QCA and openssl i installed without any problems. But now i have to compile qca-ossl. While compiling some error comes. The error is given below, pls check it and pls help me to resolve this issue!

C:\qca-ossl-2.0.0-beta3>mingw32-make
mingw32-make -f Makefile.Debug all
mingw32-make[1]: Entering directory `C:/qca-ossl-2.0.0-beta3'
C:\Qt\2010.05\qt\bin\moc.exe -DUNICODE -DQT_LARGEFILE_SUPPORT -DOSSL_097 -DQT_DL
L -DQT_PLUGIN -DQT_CORE_LIB -DQT_THREAD_SUPPORT -I"..\Qt\2010.05\qt\include\QtCo
re" -I"..\Qt\2010.05\qt\include" -I"..\local\include" -I"..\qca-2.0.3\include\Qt
Crypto" -I"..\Qt\2010.05\qt\include\ActiveQt" -I"debug" -I"..\Qt\2010.05\qt\mksp
ecs\win32-g++" -D__GNUC__ -DWIN32 qca-ossl.cpp -o debug\qca-ossl.moc
g++ -c -g -frtti -fexceptions -mthreads -Wall -DUNICODE -DQT_LARGEFILE_SUPPORT -
DOSSL_097 -DQT_DLL -DQT_PLUGIN -DQT_CORE_LIB -DQT_THREAD_SUPPORT -I"..\Qt\2010.0
5\qt\include\QtCore" -I"..\Qt\2010.05\qt\include" -I"..\local\include" -I"..\qca
-2.0.3\include\QtCrypto" -I"..\Qt\2010.05\qt\include\ActiveQt" -I"debug" -I"..\Q
t\2010.05\qt\mkspecs\win32-g++" -o debug\qca-ossl.o qca-ossl.cpp
qca-ossl.cpp: In function 'X509_EXTENSION* opensslQCAPlugin::new_subject_key_id(
X509*)':
qca-ossl.cpp:339: warning: deprecated conversion from string constant to 'char*'

windres -i qca-ossld_resource.rc -o debug\qca-ossld_resource_res.o --include-dir
=. -DUNICODE -DQT_LARGEFILE_SUPPORT -DOSSL_097 -DQT_DLL -DQT_PLUGIN -DQT_CORE_LI
B -DQT_THREAD_SUPPORT
g++ -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-rel
oc -mthreads -Wl -shared -Wl,--out-implib,lib\libqca-ossld2.a -o lib\qca-ossld2.
dll debug/qca-ossl.o  -L"c:\Qt\2010.05\qt\lib" debug\qca-ossld_resource_res.o -L
C:/local/lib -llibeay32 -lssleay32 -lgdi32 -lwsock32 -LC:/qca-2.0.3/lib -lqcad -
lQtCored4
c:/qt/2010.05/mingw/bin/../lib/gcc/mingw32/4.4.0/../../../../mingw32/bin/ld.exe:
 cannot find -lqcad
collect2: ld returned 1 exit status
mingw32-make[1]: *** [lib\qca-ossld2.dll] Error 1
mingw32-make[1]: Leaving directory `C:/qca-ossl-2.0.0-beta3'
mingw32-make: *** [debug-all] Error 2
share|improve this question

1 Answer 1

up vote 0 down vote accepted

I got it. I read somewhere that it cant create debug files by itslef. so i tried using configwin.bat r simply. and it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.