Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using VLC media player in my Windows 7 (RC), the audio works only if my head phones are connected. Without the head phones, the audio is not heard at all. Other players deliver the audio perfectly. Is this caused by some incorrect preferences ?

share|improve this question
    
Have you set your speakers as the default playback device in your sound options? –  Marcel Benthin Aug 21 '09 at 19:11
1  
Vijay, could you post what sort of audio card or built-in audio you have if you know? –  Kyle B. Aug 25 '09 at 15:13

4 Answers 4

up vote 2 down vote accepted
+100

Seems your audio drivers are installed correctly as other apps work. Have you tried the windows audio mixer (with vlc open and playing click on the audio tray bar icon > mixer > check vlc audio level). Otherwise I would check the audio options of vlc (Tools > Preferences > check all settings in the lower left corner > Audio > try some settings here and under Output modules.

share|improve this answer
    
The audio level for VLC in the mixer was zero. Once I increased it, the audio works perfectly! Thanks Andi! –  Vijay Dev Aug 27 '09 at 16:26

As RGKess pointed out, this is most probably caused by a feature in Windows 7 called "stream switching". For more information you can check out this blogpost or this video. The key is that it only works when the application uses the default sound device, so your best bet is to play around with the audio output options available in VLC.

share|improve this answer

Check the drivers for your sound card. While sound works out-of-the-box on all 6 computers I've installed the Windows 7 RC on, there's always been some funky behavior until I get the latest drivers from either the computer vendor or the sound card manufacturer.

Keep in mind that while most of these drivers will show up as a Windows Update, not all of them will...

share|improve this answer

There is a setting to automatically mute the output volume to either the headphones or the speakers, based on the source of the sound (e.g, so your ventrillo for WoW only comes out your headphones and not your speakers). It's likely that the VLC output stream is being picked up as a push to talk application of some sort.

UPDATE:

The setting I was thinking of is, I believe, called 'Stream Switching'.

share|improve this answer
    
Could not find any such setting. –  Vijay Dev Aug 19 '09 at 16:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.