Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried to solve the following problem with no luck and I need some proffesional help.

The following is possible:

  • Ping all computers (that I tried) in the domain without problem.
  • Ping myself with localhost which use ::1.
  • Ping myself with my given ipv6 IP.
  • Internet access.

The following is not possible:

  • Noone can ping me (request timeout) with computername/ipv4/ipv6.
  • I cannot ping myself with my given ipv4 IP or (request timeout).

Tried to enable/disable TCP/IPv4. Same issue.

Turned off windows firewall. Added an inbound rule to allow icmp (just in case). Same same..

Is there someone out there that has any idea what the issue could be?

Any help would be most appreciated!

share|improve this question

By default the Windows 7 firewall is configured to not respond to ping requests. You can change this behavior by following tutorials like this by

You can additionally verify that Network Discovery and File and Printer Sharing are turned on (Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings).

share|improve this answer
Thanks for thef ast answer.Tried the guide (although firewall is turned off). Did not work:( – user68546 Feb 21 '11 at 17:52
@user68546 - I edited the answer, try checking the additional options. – edusysadmin Feb 21 '11 at 17:55
Yes..everything is turned on under "advanced sharing settings" – user68546 Feb 21 '11 at 18:31

Its a tcp/ip issue if you cannot ping the local host.

See this answer on how to reinstall the tcp/ip protocol driver

how to reinstall the TCP IP protocol driver on windows 7 ?

or malware has infested your hosts file.


share|improve this answer
Ok! Thanks for the suggestion. I will try it right away. – user68546 Feb 22 '11 at 7:21

The strange behaviour disappeared after I uninstalled all my VPN clients (I'm working for different customers).

One of these "clients" was probably "something more" then just a client and blocked my computer from the incoming ping calls.

After uninstallation everything works as intended. Time to start installing all these VPN clients on a virtual computer:)

Thanks everyone for your great feedback. As usual, I was the weakest link, not the hardware/software:)

share|improve this answer

Try resetting ipv4 with:

>netsh interface ipv4 reset

See 299357 - How to reset Internet Protocol (TCP/IP)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.